View Issue Details

IDProjectCategoryView StatusLast Update
0005232Multi Theft Auto : San AndreasScriptingpublic2010-03-23 18:20
ReporterkwksndAssigned Toccw 
PriorityurgentSeveritymajorReproducibilityrandom
Status resolvedResolutionfixed 
Product Version 
Target Version1.0.4Fixed in Version1.0.4 
Summary0005232: Objects missing after being created
Description

i've noticed this destroyElement() bug and im positive the same issue effected attachElement() too a while back but i could never pin it down until now.

my new shooting range script creates and destroys objects quite quickly
if destroyElement() cant find the item specified to be destroyed,
it destroys the newest created thing regardless of what script its from.

imo this is a very serious issue.
it ends up creating an endless spam of script errors

what i think is happening is a script creates an element
and due to suspected streamer issue it doesnt get created
then said script at some point tries to destroy the element
it destroys the last created element instead,
and that sends that script into errors as well and it snowballs.

Additional Information

after some testing im possitive of this issue now i just cant tell if its a streamer issue or if its an issue with destroyElement().
i think it is a combo of both actualy
i think a streamer issue is present and its helping to expose this destroyElement()one, making it more obvious

i was creating cars using freeroam resource
and they would disapear before i could get in

i was also restarting my cargo plane script as i worked on it
and the whole plane would disapear before it could start moving
nearly every time i had to restart it twice.

TagsNo tags attached.

Relationships

related to 0005114 resolvedccw Disappearing blips 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change