View Issue Details

IDProjectCategoryView StatusLast Update
0005209Multi Theft Auto : San AndreasClientpublic2010-02-20 16:13
ReportervarezAssigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOSXPOS VersionSP3 PL
Product Version 
Target Version1.0.4Fixed in Version1.0.4 
Summary0005209: GUI buttons stop to work (onClientGUIClick event dont work AT ALL)
Description

Bug causes onClientGUIClick not working at all, tried to even outputting anything on whereever-click.

Steps To Reproduce

Hit Esc - and BEFORE it stop fade hit Esc again to get back to game.

Additional Information

Reconnecting helps. Bug exist in 1.0.3 and 1.0.2, not tested other versions.

TagsNo tags attached.

Activities

x86

2010-02-18 22:04

administrator   ~~0011068

Had the same problem, but fixed it with: guiBringToFront.

varez

2010-02-18 22:33

viewer   ~~0011069

sebassje - on which element i should use guiBringToFront? tried on window that is parent of button, and on one of buttons - not helped

ccw

2010-02-19 00:39

administrator   ~~0011070

Double pressing Esc erases the mouse click handlers in the c++ code. I doubt guiBringToFront will help in this case.

ccw

2010-02-19 01:10

administrator   ~~0011072

Fixed as of 1.0.4-untested-14 with http://github.com/multitheftauto/multitheftauto/commit/ac1db3ebb9c5223ed8d6ffaaaab20a821c254d76

varez

2010-02-19 11:01

viewer   ~~0011073

well ccw, i dont know c++ almost at all, can i fix this with lua in < 1.0.4 ? you and sebassje said that guiBringToFront will help, but i dont know on which gui element i should use it

x86

2010-02-20 16:13

administrator   ~~0011075

Use a window GUI element, which has a button.

Issue History

Date Modified Username Field Change