View Issue Details

IDProjectCategoryView StatusLast Update
0005200New issuesServerpublic2010-03-03 16:26
ReportericedsunAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Summary0005200: A player is still considered inside a vehicle if they jump out of a moving one (until done rolling on ground)
Description

When a player exits a moving vehicle, serverside functions (haven't tried clientside) still see the player element as being inside the vehicle up until the rolling on the ground animation has finished. getVehicleOccupant() will still return the player element for the seat they were in. getElementPosition() will still return the same positions for both the player and vehicle elements. isPedInVehicle() returns true for the player element.

Steps To Reproduce

Set the onVehicleDamage serverside event to output debug messages using the functions mentioned above and try jumping out right before a vehicle is about to crash into a wall.

TagsNo tags attached.

Relationships

duplicate of 0004458 resolvedIJs Multi Theft Auto : San Andreas isPedInVehicle delay 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change