View Issue Details

IDProjectCategoryView StatusLast Update
0005135Multi Theft Auto : San AndreasGeneralpublic2010-07-02 20:27
ReporterPaul_CortezAssigned ToCazomino05 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0005135: MTA doesn't send correct data to XFire
Description

Since some time there has been XFire support in the MTA source. Which is intended to show info like the Gamemode and Map the player is playing on.

Problem is though, in the XFire window you see this:

Map
Gamemode

They're plain empty. The reason behind this seems to be line 278 in CConnectManager. It adds a new entry to the "Recently played", assigns it with an IP and Port, and a few lines after that it tries to acquire the gamemode (for instance) from the "Recently played" entry. However, the gamemode hasn't been defined in that entry, resulting in an empty string.

The solution would be to query the server for necessary data repeatedly while being connected. Acquiring info something between like once per minute or once per 5 minutes. Besides getting the correct information (hopefully) you would also be able to actually keep it up-to-date.

Additional Information

This isn't really an high-priority issue, but:

  1. It's very convenient to know what your friends are playing without having to use Game-monitor or join the player's IP shown in XFire
  2. Showing empty strings in XFire, interesting as it may seem, just isn't helpful

Also, I would request to not just query the map and gamemode, but also:

  • Server name
  • Player name
  • Player count
TagsNo tags attached.

Relationships

has duplicate 0004547 closed New issues xFire support doesn't work 100% 

Activities

Cazomino05

2010-07-02 20:27

reporter   ~~0011675

Fixed in r1798

Issue History

Date Modified Username Field Change