View Issue Details

IDProjectCategoryView StatusLast Update
0005114Multi Theft Auto : San AndreasServerpublic2010-03-22 22:44
ReporterrobholAssigned Toccw 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformAny, as far as I knowOSn/aOS Versionn/a
Product Version1.0 
Target Version1.0.4Fixed in Version1.0.4 
Summary0005114: Disappearing blips
Description

It's been happening for quite some time on 1.0 and newer versions. After the server has been up for some time, blips start disappearing, apparently at random. (Yes, I said random, MUHAHAHAHA!)

I'm not the only person who has spotted this; apparently it doesn't start until the server has a few days of uptime.

The problem may be (VERY temporarily) fixed by restarting the resource that created the blips, but they'll disappear soon again.

Steps To Reproduce

Get a server with a few days runtime, (around 5 days, according to Callum,) create blips and watch them disappear.

Additional Information

The problem doesn't happen "all the time", and of course it never happens when you WANT it to happen, so you can take a closer look at the problem.

I remember running some "diagnostic" tests on my server, and it seems that createBlip still returns true. When the blips disappear, so do (apparently) their elements. This makes it possible to use some fugly hack in which you check regularly for a player's blip and create it if it doesn't exist, but this really shouldn't be necessary.

The problem has been known to happen at my server, the old FMJ Deathmatch server, Simbad de Zeeman's server, and several other places. This makes a script fuckup somewhat unlikely. Hence this report.

TagsNo tags attached.

Relationships

related to 0005232 resolvedccw Objects missing after being created 

Activities

robhol

2009-12-13 18:31

reporter   ~~0010877

Will someone PLEASE fix this, it's extremely annoying..

ryden

2009-12-13 18:33

manager   ~~0010878

Maybe it's the resource what is failing?

robhol

2009-12-14 13:05

reporter   ~~0010879

No. It happens on several servers running several scripts and it's very unlikely all scripts fail completely randomly while working perfectly at other places.

This should be looked into as soon as possible, because the only way to circumvent the bug at the moment is creating blips every X seconds and this is somewhat wasteful. Not to mention it REALLY shouldn't be necessary as I didn't order suicide blips. ;)

ccw

2009-12-17 09:42

administrator   ~~0010889

Is this only with server side created blips?
Is it with createBlip() or createBlipAttachedTo() ?
Also, please upload the work-around script.

robhol

2009-12-18 11:28

reporter   ~~0010893

Both. The workaround script essentially stores player blips, destroys them if possible and recreates them at a time interval.

Ca11um

2010-02-22 17:20

reporter   ~~0011076

This hasn't happened to me since 1.0.3 was released, but I must admit my server is always restarting and/or crashing lately, so I can't confirm it. And would this happen to effect GNU/Linux servers only? My server is a Linux and it gets this problem, I also asked on THE MATRIX, which is a Linux, and they said they get the same problem. And on servers using windows (such as SAES RPG) they seem to never have a problem with "disappearing blips".

[SAES]Tuna

2010-03-05 16:41

viewer   ~~0011117

This has happened with player blips, but haven't seen this in many weeks now. The reason why this might not have been occuring was because server is always crashing so never up for more than a few days so unable to reproduce here.

robhol

2010-03-05 16:58

reporter   ~~0011118

Callum and Tuna (especially the former): Please don't "play this down" by saying it doesn't happen anymore when you have no way of knowing that - no long uptime, no occurence of this bug.

I don't have access to a hosted server at the moment, and as such I can't verify anything myself, but I am reasonably sure it did also happen on 1.0.3.

ccw

2010-03-21 16:43

administrator   ~~0011222

Fixed in http://github.com/multitheftauto/multitheftauto/commit/7072f4d1a14c75d8aca39421fff3a5af566fd754

Issue History

Date Modified Username Field Change