View Issue Details

IDProjectCategoryView StatusLast Update
0005086Multi Theft Auto : San AndreasClientpublic2010-02-28 23:24
ReporterMCvarialAssigned ToFlobu 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.0.4Fixed in Version1.0.4 
Summary0005086: Functions to get an idea of the chatbox layout.
Description

It may be useful to have functions to know the size of the chatbox, the number of lines, etc to avoid gui's being on top or behind the chatbox, making a resource that allows the usage of smiley's, etc

TagsNo tags attached.

Activities

Flobu

2009-10-31 05:45

updater   ~~0010774

Last edited: 2009-11-07 16:04

its a client-side function

float/int[, int, int, int] = getChatboxLayout( string CVAR )

CVAR : one of the chat CVARs (looks like "chat_")

for colors it returns r,g,b,a
for "chat_scale" it returns x,y
for all others it returns the cvar as float

if the specified CVAR doesn't exist it returns false

http://github.com/Flobu/multitheftauto/commit/0bcfbb2bcd3670a32c07560d68cf73954f00b211

if I try to get "chat_text_color" an error occurs for me

Flobu

2010-02-28 22:04

updater   ~~0011098

Last edited: 2010-05-08 02:17

http://github.com/Flobu/multitheftauto/commit/ad3151c2b71d0bcf16b1c3ad390248353b37c1ac

now this it returns a table now
https://code.google.com/p/mtasa-blue/source/detail?r=1598

Issue History

Date Modified Username Field Change