View Issue Details

IDProjectCategoryView StatusLast Update
0005085Multi Theft Auto : San AndreasServerpublic2009-12-11 04:36
ReporterAthosAssigned Toccw 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0.2 
Target Version1.0.3Fixed in Version1.0.3 
Summary0005085: RadarArea Error
Description

When you create a radararea(I think it only happens with big ones, cause I haven't tested small areas)
the "pivot" of this area(which is in left-bottom-corner) changes to center, that causes the error.
The uploaded picture explains better...

TagsNo tags attached.

Activities

ccw

2009-11-28 21:02

administrator   ~~0010814

Do you mean the radar area moves sometime after creation?
Or does the displayed radar area not match up with isInsideRadarArea() ?
Or something else?

Some example script to support your description would also help.

Athos

2009-11-30 21:12

viewer   ~~0010819

Last edited: 2009-11-30 21:16

yeah... the isInsideRadarArea() doesn't match with the radar area.
Start the script: http://athos.pastebin.com/f5008c1d4
and follow the instructions: http://a.imagehost.org/view/0633/mta-screen-error-radar-area

I also have noticed, the createRadarArea() was supposed to create radar area on centerX, centerY (accordingly to the wiki). but it is creating from left -> right, bottom -> top. I think the error might be in the createRadarArea().

ccw

2009-12-05 01:41

administrator   ~~0010833

The problem is that the radar area's origin is in fact the bottom left corner, and not the center (as you point out).
It's a bit late to change how that works now, so I've 'fixed' it by updating the wiki. Unfortunately this means that isInsideRadarArea() will never work correctly as it assumes that the origin was the center. I've updated the wiki entry for that function as well with an example on how to work around it.

ccw

2009-12-11 04:35

administrator   ~~0010843

Fixed in 1.0.3-rc-4 with http://github.com/multitheftauto/multitheftauto/commit/8a41d15f3e96fe55cb8fee63a9fa75ab68286ace

Issue History

Date Modified Username Field Change