View Issue Details

IDProjectCategoryView StatusLast Update
0005082Multi Theft Auto : San AndreasGeneralpublic2010-02-02 01:40
ReporterTalidanAssigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version1.0.4Fixed in Version1.0.4 
Summary0005082: Reenable the vid command
Description

The "vid" command should be reenabled in order to tackle issues regarding this:
http://forum.multitheftauto.com/viewtopic.php?f=104&t=25244&p=295789&hilit=1920

This is a temporary measure to counteract the D3D Device reset causing the resolution to be reverted (This reset is used to make windowed mode work better)

TagsNo tags attached.

Relationships

related to 0005081 resolvedArc 1920x1080 resultion not available 

Activities

IJs

2009-12-23 14:30

administrator   ~~0010907

http://github.com/multitheftauto/multitheftauto/commit/3d9e323c65e4331383f199b5931a4f0bd273c2a1

IJs

2009-12-24 15:30

administrator   ~~0010925

Reverted due to problems concerning the implementation of CCommandFuncs::Vid and CVideoModeManager/CVideoModeManagerInterface.

The original 'vid' command was replaced in this SVN revision:

http://code.google.com/p/multitheftauto/source/diff?spec=svn1653&r=1179&format=side&path=/trunk/MTA10/core/CCommandFuncs.cpp&old_path=/trunk/MTA10/core/CCommandFuncs.cpp&old=1014

x86

2009-12-25 10:19

administrator   ~~0010926

Last edited: 2010-01-21 14:10

Is this still needed, because Arc's patch fixes to use all resolutions.

Talidan

2010-02-02 01:40

administrator   ~~0011021

No longer an issue after various other patches.

Issue History

Date Modified Username Field Change