View Issue Details

IDProjectCategoryView StatusLast Update
0005026Multi Theft Auto : San AndreasClientpublic2010-06-21 09:03
ReporterdutchturkAssigned Toccw 
PrioritylowSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version1.0 
Target Version1.1Fixed in Version1.0.4 
Summary0005026: Improve serial algorithm to reduce duplicates
Description

Aye

as the title says its possible to ban 2 persons in the server with only 1 serial.

so how is the serial produced atm?
is the serial manual editable?
is it possible to multiclient a client? (open 2 mta's) so you can have the same serial
and as last an evidence that it is possible [see attachement]

Additional Information

Very rare...

TagsNo tags attached.

Activities

dutchturk

2009-09-28 15:07

viewer   ~~0010589

http://i35.tinypic.com/2sble2g.png

i was the only admin at that moment so the other is not 'normal' banned (command)

Arc

2009-09-28 15:08

administrator   ~~0010590

The serial system is disabled. Do not use serials for banning.

IJs

2009-09-28 15:15

administrator   ~~0010591

Maybe it would be better to nop the serial banning functions.

dutchturk

2009-09-28 15:18

viewer   ~~0010592

so banning a person doesnt help alot.. change ip tadaa.. bah

btw remove the command if its unkown where the serials come from

Dragon

2009-09-28 16:51

reporter   ~~0010593

the solution to this issue is to re enable the serial and user name system (as well as make it work again), but it currently has no high priority, so for a temporary fix the admin resource should have those buttons locked.

IJs

2009-09-28 18:35

administrator   ~~0010598

Who's in favour of just removing all references to serials in future releases to prevent these issues?

robhol

2009-10-08 06:54

reporter   ~~0010657

I'm strongly against it. Serials should be left open in my opinion, and rather be fixed as soon as possible instead of dumped and disabled.

-Please- don't disable them. IP bans are 99.999999999% useless and there are no other ways of banning people that are even semi-reliable.

Talidan

2009-10-08 14:30

administrator   ~~0010658

I'm not sure why all references weren't removed for 1.0 already, that was the initial intention. The serials system is all wishy-washy at the moment. However, it may also be too late to disable them since we already provided support.

[SAES]Tuna

2009-10-09 20:34

viewer   ~~0010668

Working serials would be extremly helpful in keeping servers cheater clean. Like people have previously mentioned IP bans are not effective when a player can just keep coming back, i've had to ban 1 person over 60 times because he could change his IP instantly, that was quite annoying. But it's up to you though.

ccw

2009-10-12 00:01

administrator   ~~0010686

I've tweaked the serials to reduce the chance of 2 people ending up with the same one.

IJs

2009-12-23 14:21

administrator   ~~0010906

Changed bugreport.

Issue History

Date Modified Username Field Change