View Issue Details

IDProjectCategoryView StatusLast Update
0005025Multi Theft Auto : San AndreasClientpublic2011-01-06 01:24
ReporterPaul_CortezAssigned Toizstas 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0 
Target Version1.1Fixed in Version1.1 
Summary0005025: Serious weapon desynch upon using giveWeaponAmmo on a weapon without ammo
Description

Using giveWeaponAmmo on empty guns will cause serious desynch effects. You get the ammo in the top-right of the screen. However, when you fire, you get problems depending on the weapon type:

  • Shooting weapons (like the Colt) will locally give a shooting animation. But no bullet appears. Remotely though, people see you shoot. In the meantime, you don't lose ammo. This basically means that you're firing free ammo.

  • Projectile weapons (like the Molotov) will locally give you a throwing animation. But no projectile appears. Remotely though, the projectile appears. But on impact, nothing happens. The projectile simply disappears.

Steps To Reproduce
  1. Get on a server with at least 1 other person.
  2. In runcode or any other resource, give yourself a weapon.
  3. Shoot until you run out of ammo
  4. In runcode, now do "giveWeaponAmmo(player,[weapon ID],1)"
  5. Shoot. Be surprised no bullet appears for you, and say "OMG" in chat. While the other is surprised you fire more than 1 bullet, and says "HAX" in chat.
Additional Information

giveWeapon seems to work fine.

TagsNo tags attached.

Activities

arranTuna

2010-08-08 20:50

manager   ~~0011932

This could be solved by simply removing giveWeaponAmmo, because according to its wiki page, there isn't anything this function does that giveWeapon can not, and this bug is present in 1.0.4

ryden

2011-01-06 01:23

manager   ~~0012469

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=2222
and http://code.google.com/p/mtasa-blue/source/detail?r=2224

Issue History

Date Modified Username Field Change