View Issue Details

IDProjectCategoryView StatusLast Update
0005023Multi Theft Auto : San AndreasServerpublic2010-07-02 20:26
ReporterIJsAssigned To 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0 
Target Version1.1Fixed in Version1.1 
Summary0005023: Keep ASE query version compatible across minor versions
Description

The server browser currently filters away any versions thats are not equal to MTA_DM_ASE_VERSION (defined in version.h). This version define currently changes with each release.

Releases with the same major.minor version (1.0.x, major.minor.revision) should be compatible with each other. The server browser needs to be adjusted in such a way that all servers with the same major.minor version are all listed.

The MTA_DM_ASE_VERSION define could possibly be eliminated in favour of the MTA_DM_VERSION or MTA_DM_VERSIONSTRING defines.

TagsNo tags attached.

Activities

IJs

2009-09-29 22:23

administrator   ~~0010611

We will leave MTA_DM_ASE_VERSION to 1.0 for now to keep future 1.0.x servers backwards compatible with the server browser in 1.0. The versioning will have to be revised at a later point in time.

Talidan

2010-02-02 02:26

administrator   ~~0011035

Seems appropriate for 1.1.

Cazomino05

2010-07-02 20:26

reporter   ~~0011671

Seems fixed I updated the version define to make sure it auto updates the ASE query define when you change the major or minor version to be safe

Issue History

Date Modified Username Field Change