View Issue Details

IDProjectCategoryView StatusLast Update
0005022Multi Theft Auto : San AndreasServerpublic2009-09-29 21:56
ReporterIJsAssigned ToIJs 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
PlatformOSBSD/MachOS Version
Product Version1.0 
Target Version1.0.1Fixed in Version1.0.1 
Summary0005022: Server does not compile and run on BSD/Mach systems
Description

The server software does not compile on BSD/Mach systems (Mac OS X, Darwin) due to some Linux-specific dependencies such as librt and various clock functions.

TagsNo tags attached.

Activities

IJs

2009-09-27 13:18

administrator   ~~0010583

Fixed in ijsf/multitheftauto (b6ea2894ca0a36243798b31bb7375a30d83b2962). librt is now only configured in configure.ac when necessary, using a host rule. Mach monotonous clock functions have been implemented in (c1f9ae7bb075bd4ceb1228fb9c77e13450390d7e).

IJs

2009-09-28 01:00

administrator   ~~0010586

Server is now verified to be working and running on Mac OS X v10.5.

Issue History

Date Modified Username Field Change