View Issue Details

IDProjectCategoryView StatusLast Update
0004987Multi Theft Auto : San AndreasSynchronizationpublic2012-02-08 20:35
ReporterkwksndAssigned Tokevuwk 
PrioritynoneSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0 
Target Version1.3.1Fixed in Version1.3.1 
Summary0004987: isPedInWater ( ped ) doesnt set back to false if you warp into a vehicle from the water
Description

isPedInWater ( ped ) doesnt set back to false if you warp into a vehicle from the water

the ped/player is considered to be in the water until he gets out of the vehicle he warped into from water

Steps To Reproduce

walk into the water so you are swimming
isPedInWater ( ped ) will be set to true

warp into a boat from the water
isPedInWater ( ped ) will not be set to false until you get out of the boat on foot

if you warp from vehicle to vehicle isPedInWater ( ped ) will never get set back to false.

TagsNo tags attached.

Relationships

related to 0006560 closed Source patches Fix for isPedInWater 

Activities

Ca11um

2011-08-22 17:34

reporter   ~~0014400

Cannot reproduce this in 1.1 (using both isPedInWater & isElementInWater).

arranTuna

2011-08-22 18:11

manager   ~~0014404

Bug is still reproducable (1.1 r3042)

Ca11um

2011-08-22 20:58

reporter   ~~0014406

http://bugs.mtasa.com/view.php?id=6390

kevuwk

2012-02-08 20:35

administrator   ~~0015985

fixed server side as I couldn't find a problem client side

Issue History

Date Modified Username Field Change