View Issue Details

IDProjectCategoryView StatusLast Update
0004961Multi Theft Auto : San AndreasClientpublic2009-11-29 17:04
ReporterMr.HankeyAssigned Toccw 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version1.0.1 
Target Version1.0.3Fixed in Version1.0.3 
Summary0004961: Vehicles not getting updated anymore
Description

It can happen that all vehicles are getting stuck locally at their last position and won't be updated anymore. After some time it can happen that single vehicles are being updated properly again but overall only reconnecting fixes this. Everything else seems to work pretty well even the vehicle models are getting updated accordingly.

Additional Information

I was playing race when this occured and during the starting phase (countdown) all vehicles were at their spawnpoint but they got warped back to their "stuck" position immidietly after the race started.

TagsNo tags attached.

Relationships

related to 0004760 resolvedccw Players staying in spawn desync 
related to 0005109 resolvedccw Sync: No sync with larger amount of players 

Activities

Siyo

2009-10-09 21:10

reporter   ~~0010669

I can confirm this and it's very common. My packet loss is pretty high when it happens and It's usually fixed by itself after 2-3 minutes or after reconnecting.

ccw

2009-10-15 17:32

administrator   ~~0010697

I've added a non-optimal work around for this in http://github.com/multitheftauto/multitheftauto/commit/9f4c0c8bdabe6f5179a058620196c8d9f4e6d3b7

It's available for testing in http://nightly.multitheftauto.com/mtasadm-1.0.2-untested-27-20091015.exe

I'm pretty sure the problem is in the RakNet version we are using. The best way to fix this properly will be upgrade RakNet at the next major MTA revision. i.e. 1.1

Flobu

2009-10-15 22:38

updater   ~~0010700

I can confirm this too it happened very often for me.

ccw

2009-11-22 19:26

administrator   ~~0010805

Possibly fixed in http://nightly.multitheftauto.com/mtasadm-1.0.3-untested-5-20091122.exe [^]

Note: This is mainly a server side issue. Use the server from the link above.

Issue History

Date Modified Username Field Change