View Issue Details

IDProjectCategoryView StatusLast Update
0004960Multi Theft Auto : San AndreasScriptingpublic2009-09-29 21:57
ReporterkwksndAssigned Toccw 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0 
Target Version1.0.1Fixed in Version1.0.1 
Summary0004960: fatal error (6) issue with clients joining a server with many objects in a small area
Description

this included resource was first made as a .map by woovie using the map editor

when he discovered clients get "fatal error (6)" when joining the server he decided to convert it to a script to see if that fixed the problem but clients still get "fatal error (6)" on joining the server

Additional Information

i did some testing and found it isnt any specific model causing it but it seems to be the amount of them only 160 or so in a small area.

TagsNo tags attached.

Activities

ccw

2009-09-10 23:30

administrator   ~~0010452

Line 77: createObject ( 1651, -2983.6306152344, 1314.9956054688, 545269022720 )

The Z coordinate is too big. I'll fix the crash (it shouldn't crash just because a number is out or range). In the mean time, make sure map objects have a z coord less than 100000.

ccw

2009-09-19 01:23

administrator   ~~0010512

Fixed in http://github.com/ccw808/multitheftauto/commit/e5abbea72b9c5b6bf10b83eeba12343455d6b746

Issue History

Date Modified Username Field Change