View Issue Details

IDProjectCategoryView StatusLast Update
0004956Multi Theft Auto : San AndreasGeneralpublic2011-01-23 20:24
ReporterPhatLooserAssigned ToFlobu 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0 
Target Version1.1Fixed in Version1.1 
Summary0004956: Music stops when not looped, on a 64 bit machine
Description

When you play music ingame with playSound() on a 64 bit machine and the music is not looped, it stops after about 10 seconds.
Happened to two 64 bit computers yet.

TagsNo tags attached.

Relationships

child of 0005199 resolvedFlobu Replace irrklang with the BASS audio library 

Activities

IJs

2009-09-12 19:14

administrator   ~~0010474

You're suggesting this is specific to 64-bit systems. Does this happen on 32-bit machines?

drifterCZ

2010-04-04 07:45

viewer   ~~0011333

I have 64bit and without problems... btw the game runs as 32bit process in 64bit os

Flobu

2010-04-04 22:52

updater   ~~0011335

for me the same as drifterCZ
gtasa and mta are 32 bit programs

Maccer

2010-04-28 03:37

viewer   ~~0011397

The issue is that it randomly stops. Not just after 10 seconds, it varies. It usually lasts a minute before it cuts out.

[PS]DazzaJay[AU]

2010-06-27 13:57

reporter   ~~0011657

Ive noticed this happen a lot, and i have done a lot of looking into it.

The sound will randomly cut out on Windows Vista (all vers) and Windows 7. (all vers)
The sounds do not cut out on Windows XP and XP x64 Edition

I have the feeling MTA and the "New Improved" windows sound system in vista/7 does now like MTA.

Talidan

2010-06-27 14:21

administrator   ~~0011658

Please retest on 1.1 nightly if possible. BASS should have fixed this.

Maccer

2011-01-06 21:33

viewer   ~~0012479

Why is this in the 1.2 roadmap when we have BASS now?

arranTuna

2011-01-11 12:59

manager   ~~0012527

I can confirm that this is FIXED in 1.1

Test results using Win7-64bit:

In 1.0.4:
Song 1 - cut off near the end
Song 2 - cut off instantly (all I heard was a beep)
Song 3 - cut off very close to the end
Song 4 - Played for full length

In 1.1
Song 1 - Played for full length
Song 2 - Played for full length
Song 3 - Played for full length
Song 4 - Played for full length

Issue History

Date Modified Username Field Change