View Issue Details

IDProjectCategoryView StatusLast Update
0004934Multi Theft Auto : San AndreasServerpublic2010-01-23 00:34
Reporterx86Assigned To 
PriorityurgentSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0 
Target Version1.0.1Fixed in Version1.0.1 
Summary0004934: [Linux] Can't see players or MTA elements.
Description

When you connect to a server you can't see other people, but the chatbox is working fine.
All MTA Elements are spawned on the sea (i dunno why).
Reproduced with the map "play" but no resource working.

OS: Debian Etch (4).
Someone has this issue on CentOS.

You can reproduce on:
213.186.56.111:22005 (Debian Etch)

TagsNo tags attached.

Activities

zorrigas

2009-09-02 19:59

viewer   ~~0010405

all gamemodes are affected, as did the blips.

IJs

2009-09-06 13:57

administrator   ~~0010423

We need to have more feedback on this issue. Which kernel are you guys using?

x86

2009-09-06 14:02

administrator   ~~0010424

Last edited: 2009-09-08 14:23

sebas@gh:~$ uname -a
Linux 2.6.27.10-grsec-xxxx-grs-ipv4-32

Blokker_1999

2009-09-06 14:33

administrator   ~~0010425

Problem is also present on CentOS 5.3 build. Kernel 2.6.18, GCC 4.1.2

jhxp

2009-09-06 17:32

administrator   ~~0010426

Last edited: 2009-09-06 17:44

Happens on Debian 4.0 "etchnhalf":
Linux etch 2.6.24-etchnhalf.1-686 #1 SMP Sat Aug 15 16:51:49 UTC 2009 i686 GNU/Linux

gcc (GCC) 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)

Doesn't happen on Debian 5.0 "lenny":
Linux debian 2.6.26-2-686 #1 SMP Fri Aug 14 01:27:18 UTC 2009 i686 GNU/Linux

gcc (Debian 4.3.2-1.1) 4.3.2

deskjet

2009-09-07 18:16

viewer   ~~0010433

Happens on my VPS Ubuntu "Hardy"
Kernel: 2.6.18 (some patched version by my VPS provider)

Doesn't happen on the same VPS with Debian 5 "Lenny"
Kernel: 2.6.18 (its the same, because this is a virtual server)

So the Problem is outdated software or old kernel modules?

Mr.Hankey

2009-09-08 15:13

reporter   ~~0010438

This or a similar issue also seems to happen on Windows servers.
While playing on this XIII dd server i noticed that every now and then there are people who don't seem to see anyone else (they just drive through you and usually get banned as admins think they are cheating)

ccw

2009-09-10 04:02

administrator   ~~0010450

etch problem, (and possibly other distros) has been fixed in r1641
http://code.google.com/p/multitheftauto/source/detail?r=1641

Mr.Hankey, that issue is not the same. Please report that if no one has done it yet.

maarten123

2009-11-20 21:55

viewer   ~~0010795

When can we expect a fix for centOS?

ccw

2009-11-24 01:16

administrator   ~~0010808

Last edited: 2009-11-24 01:17

The binaries from http://linux.mtasa.com/ work correctly on centOS 5.4

You may need to do this to get it to run:
yum install pcre
ln -s /lib/libpcre.so.0.0.1 /lib/libpcre.so.3

Issue History

Date Modified Username Field Change