View Issue Details

IDProjectCategoryView StatusLast Update
0004917Multi Theft Auto : San AndreasServerpublic2010-03-29 03:08
ReporterGrimReaperAssigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0 
Target Version1.0.4Fixed in Version1.0.4 
Summary0004917: Memory does not seem to be freed on resource restart
Description

When restarting a resource all elements are destroyed, but the memory seems to be still reserved by the mta server.

TagsNo tags attached.

Relationships

related to 0004920 closed New issues MTA server doesn't destroy elements correctly 
related to 0004975 resolvedccw Multi Theft Auto : San Andreas getElementsByType() sometimes returns invalid elements 

Activities

erorr404

2009-09-03 01:36

developer   ~~0010409

I don't know if this has been reported but it might be related:

I have noticed, and someone has told me (can't remember the name atm), that there is a bug sometimes when restarting resources using 'restart RESOURCENAME'.

The bug is that after restarting a resource, the elements that were created in the resource are not fully destroyed - getElementsByType() returns these bogus elements, but they are unuseable and isElement() returns false.

This doesn't happen all the time - it seems to happen when there were errors in the previous instance of the resource and you restart it with the 'restart' command. Using the 'stop' and 'start' ommands fixes the problem, however, so these commands seem to free the elements properly.

IJs

2009-12-12 00:03

administrator   ~~0010854

http://code.google.com/p/multitheftauto/source/detail?r=1642

Commit has to be checked and re-merged into git.

x86

2010-02-28 20:53

administrator   ~~0011097

Last edited: 2010-02-28 20:53

I didn't saw this memory leak since 1.0.1/1.0.2.

jhxp

2010-03-17 12:46

administrator   ~~0011178

Reopen if this is still happening.

Gamesnert

2010-03-28 14:42

developer   ~~0011274

Issue's still at large, see:

http://forum.multitheftauto.com/viewtopic.php?f=105&p=306156#p306117

ccw

2010-03-29 03:08

administrator   ~~0011281

Fixed in http://github.com/multitheftauto/multitheftauto/commit/a7bfc5641206869e53f93127b699c3663b2ae7ee

Issue History

Date Modified Username Field Change