View Issue Details

IDProjectCategoryView StatusLast Update
0004875Multi Theft Auto : San AndreasServerpublic2009-12-07 00:17
Reportererorr404Assigned Toccw 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0 
Target Version1.0.3Fixed in Version1.0.3 
Summary0004875: Vehicles lag with high player counts
Description

In a race server with a decent amount of players (20+), remote vehicles lag quite badly.

It seems like their position is being updated infrequently, causing them to stop in place every second, and then smoothly warp to the updated position (smoothly because of the interpolation).

I'm not sure if this is an unavoidable bandwidth issue or something that can be solved.

TagsNo tags attached.

Relationships

related to 0004780 closedJax Multi Theft Auto : San Andreas Modify the interpolator to only interpolate the error, and not the full position 
related to 0003119 resolvedccw Multi Theft Auto : San Andreas Improve player/vehicle interpolation and compensation 
has duplicate 0005012 closed Multi Theft Auto : Resources Short Frequent Client freeses in Race Gamemode. 

Activities

norby89

2009-08-23 12:16

updater   ~~0010330

Here's a video showing this:

http://tinypic.com/r/micm7p/3

Arc

2009-08-23 12:21

administrator   ~~0010331

This is purely due to how the interpolator works. The algorithm is fine for cars moving at normal speeds with little lag, but starts to show its bad sides at high speeds or high lag. A better interpolator is in the works.

Ywa

2009-08-23 12:22

viewer   ~~0010332

I can confirm this issue on a Phenom quad-core (10% CPU usage) with Windows 2003. Seems to start above 25 players.

Talidan

2009-09-15 15:07

administrator   ~~0010492

Should be resolved for 1.0.1 already(?)

ccw

2009-09-21 16:34

administrator   ~~0010530

This is not resolved in 1.0.1 - It is a problem that occurs when there a lots of players in a small area.

ccw

2009-10-06 19:38

administrator   ~~0010654

Hmmm, I found some slow code in the race script that was being called once a second, which kind of ties in with the pulsing effect in that video. It may or may not be cause of this specific issue.

Race r478 contains the 'fix'.

Issue History

Date Modified Username Field Change