View Issue Details

IDProjectCategoryView StatusLast Update
0004849Multi Theft Auto : San AndreasGUI / Menus / Consolepublic2009-09-29 21:57
ReporterRansomAssigned ToIJs 
PrioritynormalSeveritytweakReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.0.1Fixed in Version1.0.1 
Summary0004849: Confusing account login
Description

Someone came on irc a couple weeks ago with this issue and I just had it when I reinstalled everything and tried to setup from scratch...

When you try to login to an account on accounts.xml there are two methods:

  1. Use the nick if it happens to be the account also and type 'login [pass]'
  2. Use any nick and type 'login [account] [pass]'

So say if I want to test and make sure the account exists I type 'login [account]' expecting it to say 'invalid password' but instead I get 'no account with your nick'.

The problem was I expect that the syntax is always login [account] [pass]. Furthermore, 'no account with your nick' I might think is referring to what I input for [account] not my current name.

The main issue here is noting the difference between nicknames and accounts. 'No account with your nick' could be better as 'No account for [account typed]'

TagsNo tags attached.

Issue History

Date Modified Username Field Change