View Issue Details

IDProjectCategoryView StatusLast Update
0004829Multi Theft Auto : San AndreasVehiclespublic2011-03-28 17:22
Reporterdragonx44Assigned Toryden 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.0.5Fixed in Version1.0.5 
Summary0004829: Trains slow down in curves
Description

It seems there is bug with trains, they slow down really much in almost all curves.

TagsNo tags attached.

Activities

Mike_Traceur

2009-08-21 23:28

viewer   ~~0010305

if u drive the tram in SF it slows down to 1 unit (getElementVelocity)

scarface1994

2009-08-22 00:32

viewer   ~~0010306

Is this an actual bug or SA physics?

Blackmen

2009-08-22 09:33

viewer   ~~0010309

I think not, in the days i played SA-MP, there isn't this problem.

[CW]ExtremeR

2009-08-22 11:46

viewer   ~~0010310

Ye, it would be really weird physics to slow down tram in curves to 1 unit. And yes, there's no such thing in SA-MP and GTA SA itself.

Mike_Traceur

2009-08-23 12:37

viewer   ~~0010334

in SA-MP they don't slow down, why in MTA?

swedman

2009-10-04 15:15

viewer   ~~0010646

This is still not fixed in 1.0.1

robhol

2009-10-04 15:55

reporter   ~~0010648

This happens to all trains as well as the SF tram. It appeared rather suddenly, and was working fine for a long time in the nightly builds, until this happened.

Mike_Traceur

2009-10-18 19:18

viewer   ~~0010715

otherwise, the trains have a high acceleration, I noticed too.

Paul_Cortez

2009-10-18 21:22

reporter   ~~0010716

Something else that might have something is the fact that if you watch the train as a remote player (aka not the driver) you see it clicking on- and off-track all the time. Something like:

Rail, derail, rail, derail, rail, derail, rail..... (in something like 1-5 seconds?)

This also causes slight desynch with the remote player sometimes seeing the train sliding off the track and suddenly railing again sometimes later at times it actually doesn't slow down in a curve. I'm not sure how relevant this is to this issue, though.

Sebihunter

2010-02-04 20:35

viewer   ~~0011041

http://www.youtube.com/watch?v=B-MECwPSVqk
Video of the bug. Spawning them on hills makes them going fast and instantly derail.

Maccer

2010-02-08 01:23

viewer   ~~0011045

@Sebihunter: There's a function that disables derailing. setTrainDerailable(vehicle, false)

Brijido_XD

2010-06-30 07:04

viewer   ~~0011662

IN MTA DP 2.3 this problem is not present

ryden

2010-12-13 15:45

manager   ~~0012268

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=2109.
This was caused by the vehicle gravity changes.

Issue History

Date Modified Username Field Change