View Issue Details

IDProjectCategoryView StatusLast Update
0004821Multi Theft Auto : San AndreasServerpublic2010-12-11 06:13
ReporterNeonBlackAssigned Toccw 
PrioritynoneSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0004821: [Request] setVehicleRGBColor(element vehicle, int red, int green, int blue)
Description

A function to set the color of a vehicle to the specified color.
Maybe you could even add a bool/float reflection that makes the vehicle shiny like in enb (if that's possible).

TagsNo tags attached.

Relationships

child of 0003344 closed New Feature Requests Requested features tracker 

Activities

Tjong

2009-08-16 19:21

viewer   ~~0010221

I would also like to have a function like this, the San Andreas colors are very limited and sometimes ugly as hell. Furthermore are nearly 80% of the San Andreas colors, ones which have the main color brown or gray mixed with another and seem very boring.

1337MaVe

2009-08-16 19:27

viewer   ~~0010222

Last edited: 2009-08-16 19:29

SO USEFUL OMG LOVE THIS IDEA <3

spozel

2009-08-16 19:31

viewer   ~~0010223

Yea i would also have this feature in MTA, because if it looks like in GTA IV you think the Game isnĀ“t so old and i hate the normal colors in GTA SA and so i say "why not!".

Dragon

2009-08-17 00:07

reporter   ~~0010228

I doubt this will be possible

JacobS

2010-11-28 21:48

viewer   ~~0012209

Last edited: 2010-11-28 21:50

^ i agree.
it seems like it would be functional but the colors are probably hardcoded. If they even succeeded in making this, it would probably be crash prone.

But I still think it's worth a shot. Maybe something to work on to the lowest point of stable functionality and set aside to a future release.

Reflections, however, are a bad idea. There are so many people that can't run San Andreas well enough to begin with. Maybe if there was an option for the player to disable them then it would work. It would require alot of hardware-based coding though because ENB works with the graphics card's firmware (shaders, rendering, etc.)

x86

2010-11-28 21:53

administrator   ~~0012210

http://code.google.com/p/mtasa-blue/source/detail?r=2090

Issue History

Date Modified Username Field Change