View Issue Details

IDProjectCategoryView StatusLast Update
0004793Multi Theft Auto : EditorMap Editorpublic2011-07-28 18:40
ReporterkwksndAssigned ToarranTuna 
PrioritynoneSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version2.0Fixed in Version2.0 
Summary0004793: You cannot select trains in the map editor
Description

You should be able to select trains in the map editor.

Im not sure if this has been overlooked or if its actualy intentional due to a bug or something.

To make the editor more complete this should be included for release in my opinion.

TagsNo tags attached.

Activities

x86

2009-08-13 11:56

administrator   ~~0010195

If you spawn a train (IN-GAME) they spawns on the rails

kwksnd

2009-08-14 06:30

reporter   ~~0010198

Last edited: 2009-08-14 06:33

thats not the point
the point is you want to be able to create one with the editor and not have to go and use notepad or whatever to create a train or trailer or railcar etc

arranTuna

2011-05-12 18:36

developer   ~~0013391

Issues I found:

Trailers:
They are lacking names in browser because getVehicleNameFromModel has no return. This could be hacked in.

Trains:
This would be a lot harder because when you create one and move it around with keys it will become lost because the physical element can not move with the red box. The element viewer would also need changing to a place where the train ended up so people can preview it.

Remi-X

2011-05-12 18:39

viewer   ~~0013392

http://forum.mtasa.com/viewtopic.php?f=102&t=30185#p328302
I really thought that returned trailernames.

arranTuna

2011-05-12 18:49

developer   ~~0013393

Nice, but when they're spawned it still says "vehicle () (1)"

Remi-X

2011-05-12 18:53

viewer   ~~0013394

FFUUU SPAWN

arranTuna

2011-07-27 21:24

developer   ~~0014035

Well I was trying to add trains but unfortunately trains are such weird things it won't work.

When you place and move a train, the element position is set incorrectly and the bounding box becomes no where near the train, the editor does a setElementPosition if you hold left key for example, the position of the train updates and so does its bounding box. However the actual train does not follow, so the element position becomes mismatches with the actual position of the train.

The train element becomes desynched with the trains position because of GTA SA forcing it to the nearest train track, and the trains element position becomes wrong.

So this issue is currently, not possible to fix and the only possible work around would be to let people only place/delete a train. Not much point in that really when trains are so many issues with them.

Bpb_Xommko

2011-07-28 08:19

viewer   ~~0014036

Did you try it with setTrainDerailed?

arranTuna

2011-07-28 12:30

developer   ~~0014037

I did, but to confirm I tried again and it worked, so maybe there is a chance trains can be added to map editor.

Picard

2011-07-28 15:54

updater   ~~0014038

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-resources/source/detail?r=755 )

Issue History

Date Modified Username Field Change