View Issue Details

IDProjectCategoryView StatusLast Update
0004731Multi Theft Auto : San AndreasServerpublic2013-02-22 10:55
ReporterCazomino05Assigned Tosbx320 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.4Fixed in Version1.4 
Summary0004731: onColShapeHit isn't triggered for towed vehicles server side
Description

onColShapeHit isn't triggered for towed vehicles server side.

Steps To Reproduce

Create a colshape and drive into it while towing a vehicle, I used a col polygon while towing a tow truck with a tow truck when testing.

Additional Information

Make sure your out of the col shape when the col shape is created, Also you will notice when you exit the towing vehicle the col shape the event is triggered for the towed vehicle

TagsNo tags attached.

Relationships

related to 0006251 closed New issues onColShapeHit is not triggered by a trailer 
has duplicate 0004734 closed New issues Colshape events doesn't work on trailers instantly 

Activities

sbx320

2013-02-07 17:49

administrator   ~~0018117

Last edited: 2013-02-07 17:58

This bug seems to be caused by a lack of a check whether the trailer actually hit a colshape.
While the trailer is attached to a towing vehicle, the Puresync Packet only updates the position & rotation of the trailer, but never actually checks if a colshape has been hit. Upon detaching the trailer is synced on its own again, which then leads to a checks for the colshape on the next movement.

Solved by checking colshapes for towed vehicles.

Patch: http://sbx320.v220120813617898099.yourvserver.net/Issue_4731_CGame.cpp.patch
Testresource: http://sbx320.v220120813617898099.yourvserver.net/Issue_4731_Testcase.zip

(also fixes 0006251 which is a duplicate of this issue)

Edit: Updated the patch to register chains of towed vehicles (towtruck towing towtruck towing roadtrain towing trailer for example)

Issue History

Date Modified Username Field Change