View Issue Details

IDProjectCategoryView StatusLast Update
0004692Multi Theft Auto : San AndreasSynchronizationpublic2009-08-14 19:43
ReporterMr.HankeyAssigned ToJax 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.0 
Summary0004692: Packer's adjustible property collision desync
Description

While the visual part of the packer's adjustable property is still synced fine when moving the ramp up the collision stays for remote players like it's still down.

Steps To Reproduce

at least two players

  1. spawn a packer and some other cars
  2. try to park it on the packer
  3. turn up the adjustable property
    now the vehicles try to follow the collision physics
    sometimes for the other players the adjustable property collision isn't up yet.
    because of this the car(s) go through the adjustable property up and down.
Additional Information

local: http://i26.tinypic.com/zv5qp5.png
remote: http://flobu.fl.funpic.de/MTA/screens/mta-screen%202009-07-20%2012-05-53.png

TagsNo tags attached.

Relationships

duplicate of 0003097 resolvedJax Do not use memory to sync the height of vehicles moveable parts, such as the forklift and packer 

Activities

Flobu

2009-08-11 00:03

updater   ~~0010179

Last edited: 2009-08-11 03:44

its back
the collision model of the adjustable property isn't synced

Flobu

2009-08-14 15:29

updater   ~~0010202

the adjustable property collision isn't synced fine yet.
i added steps to reproduce

Jax

2009-08-14 19:43

administrator   ~~0010203

Ive tested this and im positive its working.
http://i25.tinypic.com/2lxazbb.jpg

Issue History

Date Modified Username Field Change