View Issue Details

IDProjectCategoryView StatusLast Update
0004684Multi Theft Auto : San AndreasOptionalpublic2010-02-02 02:18
ReporterFlobuAssigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0004684: Request: Add a better pan/balance calculation for the 3D sound
Description

Pls use a better calculation than the current one. It seems you heard the sound only right although you are looking ca 15° right away from the sound source. I think this is much too less.

Additional Information

I tried to use a angle based calculation instead of the crossproduct which is used atm, but it seems that my calculation fails. The reason for this can be that i dont know how normalizing vectors worked.

TagsNo tags attached.

Relationships

child of 0005199 resolvedFlobu Multi Theft Auto : San Andreas Replace irrklang with the BASS audio library 
child of 0003344 closed New Feature Requests Requested features tracker 

Activities

Arc

2009-07-19 12:30

administrator   ~~0010027

Ideally the sound engine would be replaced entirely. The one we are currently using (Irrklang) has its own 3D sound implementation, but using this apparently caused sound problems for some people - therefore we switched to regular sounds with manually calculated volume and pan. It would be better to find another sound engine with properly working 3D sound than trying to perfect our custom calculation.

Issue History

Date Modified Username Field Change