View Issue Details

IDProjectCategoryView StatusLast Update
0004649Multi Theft Auto : San AndreasClientpublic2009-08-16 15:04
ReporterCazomino05Assigned ToArc 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.0 
Summary0004649: Assert when using filters while server browser is loading
Description

Using filters twice when the server browser is still loading servers causes an assertion for each entry that isn't displayed so pressing ignore can take a long time.

This can be reproduced with refresh or when starting the client the first time

By using filters twice I mean clicking the sort button twice

TagsNo tags attached.

Activities

mabako

2009-07-16 19:40

updater   ~~0009977

This is not neccessarily related to doing it twice, I can get it working when clicking one times during loading of the list.

Even in Release mode, you'll see ordering does not work, newly coming servers are always as first row when "sorting".

By the way, it's a "sequence not ordered"-assertion which happens on std::upper_bound, I'd guess in CEGUIMultiColumnList.cpp:834.

Arc

2009-07-19 20:37

administrator   ~~0010040

This is because, when changing a list item's text, cegui does not re-order it to match the selected sorting column. Therefore, after choosing a sort column, the first item is added and has its text changed leaving it in the wrong position, and then the next item that is added causes the assert.

Issue History

Date Modified Username Field Change