View Issue Details

IDProjectCategoryView StatusLast Update
0004647Multi Theft Auto : San AndreasClientpublic2013-06-15 12:17
ReporterBuffaloAssigned Toccw 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0 
Target Version1.3.3Fixed in Version1.3.3 
Summary0004647: Stability errors (random texture swapping/assertions) after alt+tab
Description

Issue appears when alt-tab'ing from MTA, wardrobe interior; Pretty annoying if server uses this interior for e.g. character creation. The cause of this might be the mirror. After the bug applied, something like objects are being rendered on the screen in 2D format.

Additional Information

Graphics affected by this bug : http://img404.imageshack.us/img404/5809/mtascreen20090715171444.png
http://sebihunter.de/download/screenshots-mta/bugs/mta-screen0028.png
http://sebihunter.de/download/screenshots-mta/bugs/mta-screen0029.png

Steps to reproduce:
1) start runcode
2) crun setElementInterior(getLocalPlayer(),14)
crun setCameraInterior(14) (optional)
3) setElementPosition(getLocalPlayer(),259.03872680664, -41.963733673096, 1002.0234375)
4) alt+tab from MTA
5) alt+tab back to MTA

TagsNo tags attached.

Relationships

parent of 0007294 closed New issues Black screen when restoring MTA window in interior different than 0 
has duplicate 0005255 closed New issues ALT Tabbing while in Cobra Gym interior, then going back to game will show black screen/texture bugs 
has duplicate 0006811 closed New issues Map editor somehow draws the stuff from the screen fullscreen? 
related to 0004775 resolvedccw Multi Theft Auto : San Andreas Error when maximizing the game, crash. 
related to 0005057 closed Multi Theft Auto : San Andreas Remove ability to alt-tab when not using windowed mode 
child of 0004922 closed Multi Theft Auto : San Andreas Fix alt+tab Direct3D stability issues 

Activities

Devan_LT

2009-07-16 11:19

viewer   ~~0009975

Isn't this a GTA problem which may occur in any interior?

Buffalo

2009-07-17 17:38

viewer   ~~0009980

Last edited: 2009-07-17 17:38

It doesn't occure while testing in Single Player, so i think it's fixable.

x86

2009-07-17 17:43

administrator   ~~0009981

Last edited: 2009-07-17 17:44

Can't reproduce in r1305, tested code.. but nothing changes.

Edit:
FX Quality: Low.

Buffalo

2009-07-17 18:34

viewer   ~~0009982

Last edited: 2009-07-17 21:32

If you don't see the bug, try to increase your video options: set better FX quality and increase Anti-Aliasing.
With lower video options the bug seems pretty random.

NeonBlack

2009-08-04 18:29

viewer   ~~0010125

Confirmed for interior 15 in r1407.
It's maybe caused by interior objects that are not in the IPLs and generated dynamically by gta when entering the interior.
Often the first and second attempt to maximize ends in a flickering black screen.

Blackmen

2009-08-05 11:55

viewer   ~~0010130

At me this happen also in Single-Player.

IJs

2009-08-31 15:23

administrator   ~~0010387

Last edited: 2009-08-31 15:24

The case where random textures are overlayed on top of the view is very likely to be CEGUI or our own Direct3D GUI stuff using an invalid texture surface (due to GUI pulses while the Direct3D device was already lost during a minimize).

Bpb_Xommko

2011-02-23 13:00

viewer   ~~0012992

Got this bug accidentally appear on build 2106. http://pix.am/bp/EEKO.png

lopezloo

2012-04-07 15:19

developer   ~~0016433

This bug is called by cull (gta mirror etc. system), no interior. I'm tested it and this happens when player minimalize screen, not maximize.

lopezloo

2013-06-14 15:47

developer   ~~0018750

On version 1.3.2-release-5499 this issue does not affect.

Issue History

Date Modified Username Field Change