View Issue Details

IDProjectCategoryView StatusLast Update
0004578Multi Theft Auto : San AndreasClientpublic2009-09-29 21:58
ReporterCazomino05Assigned Toccw 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0 
Target Version1.0.1Fixed in Version1.0.1 
Summary0004578: Vehicle desync when shot with shotgun or pushed
Description

Vehicles are de-syncing when you shoot them with a shotgun (by which I mean the shotgun moves the vehicle) and then the syncer does not update the position.
This requires 2 players but only one player has to do anything
Steps to reproduce:
start broph
Do the next steps with the client that IS NOT the syncer for the golf cart
get a sawnoff shotgun
go behind the golf cart and fire at it so it moves

Now the vehicles position should be desynced and therefore when you shoot at it the health won't update amongst other things:
when you fire at the old position (where the syncer things it is) it will take the damage

When you enter the vehicle from the non-syncer client it will slide to that position

And when the vehicle is far enough away it will cause you to be unable to enter the vehicle and teleport it back to where the syncer thinks it is.

Also when you fire at the vehicle and the syncer player is behind it he takes damage because it doesn't know the vehicle is between

Another bug this causes is de-sync between explosion locations since the vehicle is at one point on one clients machine and another at the other clients machine which means the vehicle will explode in different places for each client

Additional Information

This isn't specific to golf carts either, it happens with any vehicle but most vehicles require you to hit it at certain angles
I have reproduced it with a
sabre
mower
golf cart
kart

This also happens when a vehicle is pushed by the player

TagsNo tags attached.

Activities

Dragon

2009-07-02 14:08

reporter   ~~0009860

pushing vehicles around can have the same effect, especially with light vehicles like the caddy

ccw

2009-09-18 23:01

administrator   ~~0010508

Fixed in http://github.com/ccw808/multitheftauto/commit/c3b7bb5a3073516106e427fed959f3eae311731f

Issue History

Date Modified Username Field Change