View Issue Details

IDProjectCategoryView StatusLast Update
0004511Multi Theft Auto : San AndreasClientpublic2014-08-07 18:35
ReporterPaul_CortezAssigned ToJax 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.0 
Summary0004511: blendPedAnimation "unhandled win32 exception" if blendPedAnimation(getLocalPlayer()) is called as callback function
Description

As it's probably a bit unclear what I mean from the title, I'll show with an example:


blendPedAnimation(getLocalPlayer(),"DANCING","dance_loop",1,1,0,false,false,true,blendPedAnimation,getLocalPlayer())


This causes the local player to be "dancing" for 1 time. Then the animation is stopped, and blendPedAnimation called to reset the body to normal. (as the player still seems to e.g. lift an arm if I don't) At this moment, I get a Visual Studio Just-In-Time Debugger screen saying this:

"An unhandled win32 exception occured in gta_sa.exe [604]. Possible debuggers:[etc...]" and it asks whether I want to debug or not.

As I guess this is due to me having Visual Studio 2008, I guess it would just crash to others.

Additional Information
  • I'm using a custom-built r1164.
  • The crash does not occur if you delay blendPedAnimation(getLocalPlayer()) 1 frame.
TagsNo tags attached.

Activities

socialz

2013-03-14 14:29

viewer   ~~0018246

News to this? Will it ever be implemented again?

Cazomino05 applied a fix in version 1.0 on Thursday 25th of June 2009 22:14:23 (GMT+01:00).

But at this moment it describes it as disabled in the Wiki.
https://wiki.multitheftauto.com/wiki/BlendPedAnimation

Can you also explain what the function actually does?

Grafu

2014-08-07 18:34

viewer   ~~0021677

Last edited: 2014-08-07 18:35

View 2 revisions

Please enable this again.

Issue History

Date Modified Username Field Change