View Issue Details

IDProjectCategoryView StatusLast Update
0004510Multi Theft Auto : San AndreasSynchronizationpublic2012-01-24 21:40
ReporterjhxpAssigned Toccw 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.0.4Fixed in Version1.0.4 
Summary0004510: Death animation causing desync for players with low health
Description

If you shoot a player who has less than 50% of health points, on your screen he might start doing a death animation for half a second (he will turn around like he was going to fall to the ground in a second; his health triangle will turn black like on death), then he will slowly move from his position for a second and, in fact, won't die. If he stops and you keep shooting at him, you won't be actually hitting him.

On that player's screen, he doesn't get hit and he can move with normal speed all the time. If he does move - his position will be desynced for shooter for some distance, depending on how far he moved when the bug was happening.

Needless to say, this causes terrible desynchronization for duelling players, often leading to situations where a player with the lowest amount of health points can win a fight against a player with full hp, because the latter player can't hit him.

It's said to happen with all weapons, but especially with deagle, shotgun and spaz - also seems to happen for a good while now - it was also an issue in DP1/2's.

Additional Information

The description might be a bit dodgy, so I'll try to get a hold of a video showing this bug.

This should be it: http://www.jhxp.net/personal/mta/death-animation-desync.avi

Submitted by =PCP=csm

TagsNo tags attached.

Activities

ryden

2009-06-29 16:06

manager   ~~0009808

Probably fixed in r1219. Please re-test.

csm

2009-07-14 20:17

reporter   ~~0009966

http://www.jedson.cityhost.pl/mtamovies/4.mpg

Still not fixed.

jhxp

2009-07-26 22:46

administrator   ~~0010077

Apparently still there.

ccw

2009-07-31 07:58

administrator   ~~0010094

Small chance it's been fixed in r1373. Please re-test.

IJs

2009-09-12 16:27

administrator   ~~0010456

Please test in 1.0 asap.

arranTuna

2012-01-04 14:14

manager   ~~0015606

Has anyone ever seen this bug recently?

I haven't seen it since dp2.

LooooP

2012-01-04 15:40

reporter   ~~0015607

I never noticed it (1.0 - 1.2)

Vincent

2012-01-09 07:58

viewer   ~~0015681

Same thing, used to play a lot 1.0 - 1.2, but didn't see the bug.

jhxp

2012-01-24 21:40

administrator   ~~0015794

Please reopen if it still happens.

Issue History

Date Modified Username Field Change