View Issue Details

IDProjectCategoryView StatusLast Update
0004503Multi Theft Auto : San AndreasSynchronizationpublic2011-11-20 00:55
ReporterjhxpAssigned ToCazomino05 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.1.1 R2Fixed in Version1.1.1 R2 
Summary0004503: Glitch for shooting bullets remotely while reloading
Description

It is possible to shoot bullets remotely while your player is reloading his weapon locally.

This leads to glitchy situations where you can kill your opponent even if normally you shouldn't be able to do so.

Apparently this bug was here for a while, but got worse recently.

Steps To Reproduce

See the video.

Additional Information

http://www.jhxp.net/personal/qa_team/hitting_on_reload.avi

Same video, different codec and mirror: http://jedson.cityhost.pl/hitting_on_reload.mpg

Submitted by =PCP=csm / =PCP=d0KTOR_

TagsNo tags attached.

Relationships

has duplicate 0004902 closed New issues Ghost shot: "shooting" while reloading 
related to 0005962 resolvedCazomino05 Multi Theft Auto : San Andreas Sawnoff shotgun glitch 
related to 0006084 resolvedccw Multi Theft Auto : San Andreas Shot origin and target can be incorrect on remote clients 

Activities

ccw

2009-06-24 15:21

administrator   ~~0009713

Fixed in r1154

csm

2009-06-26 22:00

reporter   ~~0009761

It's still possible to kill while reloading.

ccw

2009-06-26 22:04

administrator   ~~0009762

I found this too. Although the occurrence has been reduced.
I'll take another look and see what can be done.

Talidan

2009-06-27 17:11

administrator   ~~0009772

Might be hacky, but a local control state fix might be the answer.

ccw

2009-07-02 08:07

administrator   ~~0009844

Problem is the reload anims are tricky to sync. If on the remote client, your guy has no ammo and the fire button is synced as being pressed, he does a reload. It usually coincides with what your guy is actually doing on your screen, but not always.

ccw

2009-07-04 02:04

administrator   ~~0009879

The solution is to implement synced animations, but that's not going to happen until 1.0.1. Anyone got any clever ideas?

roleplayman

2009-07-26 22:46

viewer   ~~0010076

Last edited: 2009-07-26 22:49

well sorry i am new in c++ but just trying to help

well you can do clientside checks like isPlayerReloading(int playerid)
it shall return 0 or 1 if playerreloading sendpacket to server that he is reloading so it will not recv any of that glitch on the targeted player

or send player bullets count to the serverside so the bullet count is synced witch will result knowledge to all the clients of isplayerreloading or not [may cause packet overload]

Jax

2009-07-30 14:59

administrator   ~~0010089

"The solution is to implement synced animations, but that's not going to happen until 1.0.1. Anyone got any clever ideas?"

I cant really fix/test this at the moment but the weapon-state is sync'd, that should be enough, maybe theres a bug with that somewhere.

Ransom

2011-02-05 07:07

administrator   ~~0012857

Last edited: 2011-02-05 07:08

I have a script that can produce this reliably for testing when the time comes to fix it. Bind a key to set the player weapon slot to something else and then back to the gun when released.

Hold aim and shoot at the person and start mashing the key. You'll kill the person using little to no bullets.

This is pretty important to fix as it really messes with competitive gameplay, it happens quite often.

PhatLooser

2011-02-23 06:56

reporter   ~~0012989

My syncro script fixed that by syncing every single bullet, which might be a solution but is actually a bandwidth-using idea.

ccw

2011-03-27 04:41

administrator   ~~0013119

Please show your syncro script

arranTuna

2011-03-27 11:28

manager   ~~0013125

This is PhatLooser's syncro script: http://community.mtasa.com/index.php?p=resources&s=details&id=1065

PhatLooser

2011-03-27 11:39

reporter   ~~0013126

Its the old one though, I updated it so clients do a check on other clients.

Hardcoded it can be made like, syncing how many bullets were shot if the player was shooting. This also would make the anticheat for MTA stronger.

samt2497

2011-08-13 19:05

viewer   ~~0014264

What about just dont trigger local client shoot while animation is being done...

ccw

2011-08-13 20:10

administrator   ~~0014265

Because blocking remote player shots based on the (out of sync) local animation will make remote players unhappy.

samt2497

2011-08-13 20:48

viewer   ~~0014267

I mean, when local player clicks, the shoot is triggered to server, what about cancel it while player is doing reload anim.

ccw

2011-08-13 20:55

administrator   ~~0014268

Doing reload anim where? Local or remote?

samt2497

2011-08-13 20:57

viewer   ~~0014269

If local CLIENT is doing reload admin, then dont trigger shoots or disable shoot key.

Picard

2011-11-16 17:45

updater   ~~0015240

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=3430 )

Issue History

Date Modified Username Field Change