View Issue Details

IDProjectCategoryView StatusLast Update
0004478Multi Theft Auto : San AndreasClientpublic2009-06-16 22:49
ReporterCazomino05Assigned ToArc 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.0 
Summary0004478: Crash on forcing head light states
Description

The game crashes on an invalid call to RwIm3DTransform at CMultiplayerSA.cpp:3493 (recent headlight code) due to RenderWare function offset differences in EU and US versions of Grand Theft Auto: San Andreas.

Steps To Reproduce

Use freeroam, get in a car and force the headlights on. Will crash on either US or EU.

TagsNo tags attached.

Activities

IJs

2009-06-16 22:26

administrator   ~~0009625

Correct offsets can be found in trunk/MTA10/game_sa/CRenderWareSA.cpp.

Issue History

Date Modified Username Field Change