View Issue Details

IDProjectCategoryView StatusLast Update
0004472Multi Theft Auto : San AndreasClientpublic2009-06-23 10:23
ReporterMr.HankeyAssigned Toccw 
PriorityurgentSeverityblockReproducibilityrandom
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.0 
Summary0004472: Players being ignored by melee/weapon attacks
Description

Since r1095 players (maybe also peds in general) can become semi-collisionless where shots and melee attacks are going right through them which results in local invincibility.

TagsNo tags attached.

Relationships

related to 0001403 resolvedIJs Players become immune to bullets 
related to 0004468 closed Having skin 0 makes you immune to bullets / Can't take damage bug 
child of 0003255 closed Priority Issues 

Activities

Jax

2009-06-17 02:06

administrator   ~~0009627

Due to NetBitStreamInterface::ReadCompressed/WriteCompressed

ccw

2009-06-17 02:29

administrator   ~~0009630

Jax, I had a quick look and couldn't see anything obvious. Can you be more specific where you found this problem? An example of what to do to reproduce the ReadCompressed/WriteCompressed error would be great.

Talidan

2009-06-18 04:27

administrator   ~~0009648

Last edited: 2009-06-18 04:35

I've checked this, and from what i can tell the symptoms of this are exactly like the immune to bullets bug (#1403) we had a number of years ago. Whether the cause is the same or not, i don't know.

Me and Fenix reproduced this in about 5 minutes using deathmatch & dm-canals.

erorr404

2009-06-18 05:22

developer   ~~0009649

Last edited: 2009-06-18 05:25

It should be noted (as was in my report) that this is a very specific bug and happens every time to players who have the CJ skin.

Also, next time please search before posting a report.

scarface1994

2009-06-18 12:51

viewer   ~~0009650

Happened with most skins here.

erorr404

2009-06-19 03:54

developer   ~~0009652

Talidan says that once it happens to a skin, it stays like that consistently, e.g. once a skin becomes immune it stays immune permanently.

ccw

2009-06-19 19:07

administrator   ~~0009655

I can reproduce it here by using two PC's:

Connect both clients to the server
Start Freeroam
Player 1: F1->skin->Celebrities->Sharon Stone->F1
Player 2: F1->skin->Formal Generics->Pilot->F1
Player 2: F1->weapon->Shotgun->F1

Now Sharon Stone can't be damaged by the Pilot's shotgun

Talidan

2009-06-20 19:44

administrator   ~~0009659

As mentioned on gc, this is down to sloppyness in r1093

Jax

2009-06-22 13:53

administrator   ~~0009672

I cant reproduce this.. could you paste me some sloppy code from it Talidan? can't find any myself.

jhxp

2009-06-22 14:00

administrator   ~~0009673

Fixed in r1129 ?

ccw

2009-06-23 03:12

administrator   ~~0009686

Fixed in r1129

Issue History

Date Modified Username Field Change