View Issue Details

IDProjectCategoryView StatusLast Update
0004463Multi Theft Auto : San AndreasClientpublic2011-08-18 01:02
ReporterGabor888Assigned ToArc 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.0 
Summary0004463: dxDrawLine3D cannot be seen if the direction is pure z (or near to the pure z)
Description

dxDrawLine3D cannot be seen if the direction is pure z (or near to the pure z)
i guess it is because of the production of the line, cause it's just a strip. This can be solve the bug: the strips sideway direction would be: lineSideWayVector = cameraLookAtVector × lineAlongWayVector, but i dont know how much work it could be, just a recommendation...

TagsNo tags attached.

Activities

Evgeni_Degerev

2011-08-18 01:02

viewer   ~~0014338

http://pastebin.com/g4cGjUfb
I can't see lines when camera angle is 344..84 ( getPedCameraRotation )

Issue History

Date Modified Username Field Change