View Issue Details

IDProjectCategoryView StatusLast Update
0004458Multi Theft Auto : San AndreasScriptingpublic2010-05-05 12:42
ReporterrobholAssigned ToIJs 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.0.4Fixed in Version1.0.4 
Summary0004458: isPedInVehicle delay
Description

isPedInVehicle shows a delay after entering and, more noticeably, after exiting a vehicle. Whether standing still and exiting, or bailing out at high speeds, the function returns true for a while after the player has left the vehicle.

The function seems to return false again only after the player or ped is standing still after exiting, so the delay when bailing at higher speeds is LONG whereas the delay when exiting normally is a lot shorter.

Can be reproduced easily, because it happens EVERY single time. Try using onClientRender and draw the returned value with dxDrawText, you'll see what I mean.

TagsNo tags attached.

Relationships

has duplicate 0004621 closed New issues isPedInVehicle returns true while ped is entering the vehicle 
has duplicate 0005200 closed New issues A player is still considered inside a vehicle if they jump out of a moving one (until done rolling on ground) 

Activities

robhol

2009-06-14 21:31

reporter   ~~0009612

Last edited: 2009-06-14 21:33

This also applies to onPlayer-/PedVehicleExit.

1337MaVe

2009-07-12 13:09

viewer   ~~0009933

Last edited: 2009-07-12 13:15

http://www.mavecoder.com/ispedinvehicleBug.avi

script im using

http://mta.pastebay.com/28964 (serverside, i'm binding a key to that function)

IJs

2009-12-12 00:18

administrator   ~~0010855

http://github.com/multitheftauto/multitheftauto/commit/9e397129049d40a1a4d70b48d94b512c9b4e1093

Commit has to be checked and re-merged into git.

Flobu

2010-02-28 23:48

updater   ~~0011106

now theres no delay after exiting a vehicle at high speeds
and if it standing still and you exist it it will return true while exiting and false if you stand near the vehicle

x86

2010-04-19 19:10

administrator   ~~0011378

Please retest, because I can't reproduce it anymore in untested-22.

x86

2010-05-05 12:42

administrator   ~~0011430

Unable to reproduce.

Issue History

Date Modified Username Field Change