View Issue Details

IDProjectCategoryView StatusLast Update
0004455Multi Theft Auto : San AndreasClientpublic2012-07-17 14:24
ReporterJohnlineAssigned Toccw 
PriorityhighSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.1Fixed in Version1.3.1 
Summary0004455: issues remain with custom model streaming/memory
Description

have been running custom model client scripts on my server for a while now testing a range of map models with varying ids.

col models can drop randomly for players, sometimes correlatively from a model; usually having the original collision for that id returning.
textures can also drop from memory making the model white, or usually when doing this the texture memory goes haywire and you get something like this:
http://screenshot.xfire.com/screenshot/natural/87cba82b00dc3d0c0c8c0f34f0fd344e6d0842cb.png

most of my custom models are in sections, so each can work differently, eg one section can drop its col, another can be fine.
for textures usually all parts get affected when it happens, and seems to be triggered by an abrupt introduction of new textures in memory, for example and explosion.

TagsNo tags attached.

Activities

ccw

2012-02-13 19:41

administrator   ~~0016058

The texture issue has been fixed.
The collision sometimes not loading is still present and affects both custom and standard models.

BinSlayer

2012-02-14 19:57

viewer   ~~0016068

Posting here since this is the actual bug report where I should have posted in the first place, and not http://bugs.mtasa.com/view.php?id=6436
"I don't think the player does something out of the ordinary when the bug happens, so steps to reproduce are nearly impossible to get. Especially because it happens to more people at the same time, but never to the whole server. 3 quarters of the server could have the bug and not be able to finish a map, while a few select people could be unaffected.

Might be best to release a nightly with debug stuff (if this is even possible) and next time it happens players can simply submit the debug log.
It will also take some time before we can get the bug again since no easy way to reproduce has been discovered"

PhatLooser

2012-02-17 14:21

reporter   ~~0016098

There is a way to reproduce: Custom objects with custom collisions which don't get unloaded when the map ends.

Issue History

Date Modified Username Field Change