View Issue Details

IDProjectCategoryView StatusLast Update
0004451Multi Theft Auto : San AndreasServerpublic2009-12-18 00:08
ReporterArctosAssigned ToArc 
PrioritylowSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.0.3Fixed in Version1.0.3 
Summary0004451: Block ability to edit game files.
Description

Hello,

I propose to block ability to edit game files, especially from data directory (weapon.dat etc.), becouse many players edit them and cheat in game (faster shooting, edited damage etc.).

This occurrence make fair players mad.

I hope you gonna accept this report and in soon future solve it. :D

TagsNo tags attached.

Activities

T3rr0rd3ath

2009-06-14 13:35

viewer   ~~0009601

Last edited: 2009-06-14 13:39

these files should be not editable and usable then:
melee.dat
object.dat
handling.cfg
surface.dat
surfaud.dat
surfinfo.dat
vehicles.ide
water.dat
water1.dat
weapon.dat
carmods.dat

all files are in the data folder btw

robhol

2009-06-14 13:46

reporter   ~~0009602

weapon.dat is no big deal. I was previously concerned about this, but unless you make a script that transfers all hit detection to client-side scripts (like the so-called desync "fixes" for dp2) this is completely irrelevant.

As for handling.cfg I agree that this should definitely be protected. The others I'm not completely familiar with, so I'm not sure what unfair advantages one would get by modifying them.

Arctos

2009-06-14 13:54

viewer   ~~0009603

Hmm... But you can block it in same way like gta3.img file I think :D

jhxp

2009-06-14 14:18

administrator   ~~0009606

Set for a later release for now.

Dragon

2009-09-13 10:05

reporter   ~~0010477

the ideal solution would be to let server owners provide those files so they can modify them matching their preferences and also provide all clients from using their owns.

trjack

2009-11-08 18:01

viewer   ~~0010783

Last edited: 2009-11-08 18:03

you wouldnt block it you would hook it and then do it that way. then if you did that you may as well make a weapon.dat serverside :)
like what dragon said basicly

Rhbk

2009-12-13 13:16

viewer   ~~0010876

Hi, I propose to block it in the version 1.0.3 because it is creating the serious problem.
More and more players are unwittingly editing settings weapons with installing packages (model, texture & confing). There are also players which are doing it intentionally, for example, increase the time the shot weapons (slowly losing the health), speeding up the animation aiming weapons or
alter injury. Of course, all modification work on players who do it.
This game slowly recalls sa-mp, if at shooting to the player from the M4, the health is coming down in 10 seconds to 50%( normal 1.5-2 s).

Scripts type sync "fixes" can't solve the problem, because then you don't know who shooting and where there is, no animation and lagers can kill you through the wall.

Sorry for my bad english, but I think you can understand this.

Maccer

2009-12-16 06:35

viewer   ~~0010886

Last edited: 2009-12-16 06:35

Fixed by ArcusMaximus's (Possibly the reporter himself Arctos(?)) revision.

ccw

2009-12-17 09:45

administrator   ~~0010890

This is now in http://nightly.multitheftauto.com/mtasadm-1.0.3-rc-9-20091217.exe

Please test!

Rhbk

2009-12-17 21:01

viewer   ~~0010892

It works good, but in future versions I propose to on connection replace data files to orginal( some do it unconsciously ).

Issue History

Date Modified Username Field Change