View Issue Details

IDProjectCategoryView StatusLast Update
0004445Multi Theft Auto : San AndreasClientpublic2009-06-30 02:16
ReporterDragonAssigned ToJax 
PriorityurgentSeveritymajorReproducibilityrandom
Status resolvedResolutionfixed 
PlatformOSWindows XP Home EditionOS Version2002 SP 3
Product Version 
Target Version1.0Fixed in Version1.0 
Summary0004445: Shooting after respawn randomly stops working
Description

This doesn't seem to be reported yet. Sometimes firing any weapon using bullets stops working correctly. You can see the animation but there is no sound or bullet. This happens for you and for other players, so if the bug happens for you others can't hurt you anymore. While you don't see yourself shooting others (sometimes) still can so they will take damage from you. However this can vary.

This can also change while on a single server. It never seems to happen before first dying and respawning, having others getting killed, yourself getting killed, players leaving and joining the server can sometimes fix the issue temporarily.

Steps To Reproduce

Have some players playing any mode dying, respawning, killing others, reconnect. I'm sorry I can't submit a proper way to reproduce this

Additional Information

Not sure if this is related anyhow but it sometimes crashed my client when others were firing with the minigun.

The issue seems to happen since ~r1026 - ~r1038

TagsNo tags attached.

Relationships

has duplicate 0004553 closed After being killed by someone, you won't see bullets from any gun anymore until your killer streams out or respawns. 

Activities

Talidan

2009-06-13 17:04

administrator   ~~0009577

Clearly related to Jax's animation changes

Dragon

2009-06-13 17:10

reporter   ~~0009578

i packed some of my later dumps http://darkdragonger.da.funpic.de/stuff/dumps.rar

slothman

2009-06-15 01:56

updater   ~~0009613

Last edited: 2009-06-15 02:06

I have been able to reproduce this issue every time a player dies, when a script first starts, the player is fine, but after they respawn from dying, they are unable to shoot any bullet weapons, animations are there, but no sound or bullets. I narrowed the cause of this on my script down to the fact that a ped exists. no peds = no problem, but the second a player respawns after a ped is created, the problem starts. i was alone in the server when testing this.

ADITIONAL NOTE: i spawned a ped a long distance away (streamed out) and there was no problem untill i got closer and the ped was streamed in, at that point it stopped working without even having to die and respawn

Jax

2009-06-15 12:02

administrator   ~~0009614

Clearly nothing to do with my code talidan!

Dragon

2009-06-29 11:51

reporter   ~~0009804

back due to revision reverts

slothman

2009-06-29 22:12

updater   ~~0009825

this isnt just happening due to respawning, I used setElementPosition serverside to warp a player and the same thing occurs (the warp btw was a very short distance, pretty much straight down 10 feet)

ryden

2009-06-29 22:27

manager   ~~0009826

Are you using the latest svn revision?

slothman

2009-06-30 02:16

updater   ~~0009829

looks like the new nightly has it fixed.

Issue History

Date Modified Username Field Change