View Issue Details

IDProjectCategoryView StatusLast Update
0004394Multi Theft Auto : San AndreasClientpublic2009-07-08 01:29
ReporterDragonAssigned ToArc 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
PlatformOSWindows XP Home EditionOS Version2002 SP 3
Product Version 
Target Version1.0Fixed in Version1.0 
Summary0004394: [Request]Ability to prevent wasted shaking cam to take over clients view / abort it
Description

Would be very useful and could also fix the inability to move camera freely on (some) spectator modes

TagsNo tags attached.

Activities

Arc

2009-05-30 16:08

administrator   ~~0009456

setCameraMatrix doesn't cancel the deathcam?

lil_Toady

2009-05-30 16:16

administrator   ~~0009458

setCameraMatrix does stop death cam

Dragon

2009-05-30 17:38

reporter   ~~0009461

Last edited: 2009-05-30 17:38

the main issue is, that setCameraTarget doesn't allow you to move the cam freely if your client is having the wasted shake cam

you can test that on stealth, if you connect while a round is running you can spectate and move the camera around the spectated player (it works perfectly because you didn't die yet) but if you die you get the shake can, now try to spectate someone and move the camera, it resets all the time, its the shaking cam which doesn't want you to be able to move the camera around

[CW]ExtremeR

2009-05-30 23:57

viewer   ~~0009462

Last edited: 2009-05-30 23:57

So does it mean that setCameraMatrix or SetCameraTarget isn't called on player join?

Dragon

2009-05-31 00:46

reporter   ~~0009464

it means that the shaking cam somehow disturbs the camera view if its not just static (like in setCameraMatrix) but should be movable (like in spectator modes which use setCameraTarget)

Talidan

2009-05-31 15:42

administrator   ~~0009471

Are you sure that the spectator camera "lock" is down to the wasted cam? It could simply be as a result of dying, something gets unloaded. There's little evidence to suggest that its directly related to the wasted cam, if you ask me.

Dragon

2009-05-31 16:06

reporter   ~~0009473

uhm well ye, it COULD be the fault of something else but some (i hope) more proper way to prove this can be found in race. finish a race and wait for the spectator mode to start. type /kill now, USUALLY the issue starts exactly after the time the death cam needs to activate when you die

unfortunately sometimes in cars it needs some more time for the player to fall out of his vehicle and get the death cam (i guess if your car is still rolling so you should probably try to avoid rolling after finish by going slow)

Issue History

Date Modified Username Field Change