View Issue Details

IDProjectCategoryView StatusLast Update
0004369Multi Theft Auto : San AndreasVehiclespublic2009-07-24 19:58
ReporterrobholAssigned ToJax 
PriorityurgentSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version1.0 
Summary0004369: Falling off bikes, random kills
Description

Sometimes falling off of a bike causes a player to die, giving the "blame" to another player. This seems to happen when people have earlier been trying to kill eachother.

Additional Information

Reproduction: Get two or more players on a server, DM for a while and then go for a nice bike ride. Crash into stuff. It seems to be random, but does happen fairly often.

TagsNo tags attached.

Activities

Dragon

2009-06-22 17:55

reporter   ~~0009676

I can confirm this weird, pretty random happening issue, when the issue starts its hardly possible stopping it, reconnecting seems to be the most proper way

Jax

2009-06-23 10:45

administrator   ~~0009693

Is the death-cause still given as 'fall'?

robhol

2009-06-23 10:59

reporter   ~~0009694

No, it seems to be the weapon the player was hit with. The supposed killer is apparently the one who last hit the player or dealt him damage in any way.

Talidan

2009-06-23 13:18

administrator   ~~0009699

This fake kill ID is common among many deaths. The last damage ID seems to play a prominent role in deciding killer and weapon, which MTA seems to use when it does not have a valid kill id.

In this respect, the reported death type may be irrelevant.

ccw

2009-06-24 12:20

administrator   ~~0009710

Fixed in r1151

Talidan

2009-06-26 02:01

administrator   ~~0009743

Its not entirely clear if this is fixed: please retest.

ccw

2009-06-26 03:19

administrator   ~~0009744

I am unable to reproduce a premature death when falling off a bike. Were there any custom scripts running when it happened?

ryden

2009-06-26 03:46

manager   ~~0009745

Have you tried having CJ wear a safety helmet?

Dragon

2009-06-26 21:16

reporter   ~~0009759

Last edited: 2009-06-26 21:24

happens sometimes on vehicle normal exit now! still pretty random, and still reporting the last death facts (killer, weapon etc)

maybe split the issue?... - but seems to be very similar to each other.

ccw

2009-07-04 01:42

administrator   ~~0009876

Seems to have gone away after recent anim reverts

robhol

2009-07-16 22:41

reporter   ~~0009979

Last edited: 2009-07-22 00:27

Still happens in r1305 through r1332.

It seems to affect player health and damage handling in a weird way. When a player has died from falling off of a bike, apparently any attempt at setElementHealth'ing his health down seems to kill him off instantly.

ryden

2009-07-24 11:28

manager   ~~0010058

Please retest in r1348.

Jax

2009-07-24 19:58

administrator   ~~0010059

Its fixed!

Issue History

Date Modified Username Field Change