View Issue Details

IDProjectCategoryView StatusLast Update
0004347Multi Theft Auto : San AndreasGeneralpublic2009-06-23 02:02
ReportersyntzAssigned ToArc 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version1.0 
Summary0004347: Remove the splash-screens and the intro videos when you start MTA: SA
Description

Would be great if MTA would skip the nVidia/EAX splashes and the intro videos when you start MTA: SA, like SA-MP does. And also perhaps replace the GTA: SA logo with the MTA: SA logo?

TagsNo tags attached.

Activities

[NB]Sneaky

2009-05-22 11:14

viewer   ~~0009301

They should be instantly skipable by pressing LMB (or any other key), instead of having to wait till the logo's are gone before you can skip it.

syntz

2009-05-22 11:15

viewer   ~~0009302

Or perhaps removed entirely?

trjack

2009-05-22 14:45

viewer   ~~0009305

This should be removed; it saves time and Lucas can make a patch.
It's annoying when testing something and your laptop battery is half gone and then used up by the ads, this would be useful.

x86

2009-05-22 14:49

administrator   ~~0009306

MTA should make a own intro.
Like this: http://www.youtube.com/watch?v=d0XVnXN5i2o

scarface1994

2009-05-22 14:54

viewer   ~~0009307

Last edited: 2009-05-22 14:55

There was once a patch for this and it's not worth it, you can also remove the splash screens your self from the GTA SA executable (gta_sa.exe) which is what I did.

And the logos are completely skip able, if LMB doesn't try your your ENTER key.

syntz

2009-05-22 15:05

viewer   ~~0009308

Last edited: 2009-05-22 15:09

Don't understand why it wouldn't be worth it?

And about MTA having its own intro, I fully agree.

This could be a sexy intro aswell: http://www.youtube.com/watch?v=CU332tMSoCg&feature=related

scarface1994

2009-05-22 15:10

viewer   ~~0009309

To tell you the truth, I too have thought about a MTA intro, but I doubt removing the GTA splash screens would be the best thing, ask someone else.

SkyBon

2009-05-22 18:09

viewer   ~~0009322

I totally agree with the idea of removal as it makes MTA launch more convenient and automatic

[M2S]moe

2009-05-22 18:11

viewer   ~~0009323

+1 about full removal, an intro no matter how awesome would get boring after the 10th connection

robhol

2009-05-22 18:29

reporter   ~~0009324

Removing might not be plausible because of legal concerns, if not common decency. However, adding a way to skip them quickly without requiring 3rd party mods (or is it 4th party? hm..) should be possible.

Also, having an MTA splash screen/intro would be nice, but hardly a major priority.

lucasc190

2009-05-22 18:32

reporter   ~~0009325

Could the NVIDIA ads be shown during the loading screen or on the MTA menu or something?

syntz

2009-05-22 20:56

viewer   ~~0009326

Last edited: 2009-05-22 20:56

robhol - You could simply use the solution they've used with SA-MP where they show the nVidia/EAX ads during the loading screens.

robhol

2009-05-22 20:58

reporter   ~~0009327

Intro screens, you mean. It's not like an MTA intro is really important though: people already know what they're playing, and the menu has Multi Theft Auto written on it with huge letters anyways.

Better to just make the EAX and nVidia intros skippable and get it over with, imo.

syntz

2009-05-22 21:02

viewer   ~~0009328

Last edited: 2009-05-22 21:05

No, not the intro screens. The loading screens.

Why should you make them skippable when you can remove them entirely? Makes no sense.

The MTA intro thing isn't important but it would be a nice addition.

And oh yeah, a patch has already been made for the main issue: http://bugs.mtasa.com/view.php?id=4350

robhol

2009-05-22 21:08

reporter   ~~0009329

There's no real point in removing them if you can just double-click and skip them in half a second. It would also be wrong, possibly violating license agreements and the like, and maybe even putting MTA at legal risk.

syntz

2009-05-22 21:10

viewer   ~~0009330

Which, again brings us to SA-MP. They've skipped those intros for a few years now without legal problems. As I said, just add the nVidia/EAX logos to the loading screens and problem solved.

scarface1994

2009-05-22 21:48

viewer   ~~0009331

I really don't see the point here, is everyone that lazy to just hit the ENTER key to skip the intros?

Talidan

2009-05-22 21:49

administrator   ~~0009332

scarface, robhol, these intros CANNOT be skipped by pressing enter, which is why it has been requested.

robhol

2009-05-22 21:51

reporter   ~~0009333

Last edited: 2009-05-22 21:51

I know they can't be skipped. I simply said that if they could, I'd be happy. I already suggested making them skippable in my previous note. ;)

scarface1994

2009-05-22 22:01

viewer   ~~0009334

Last edited: 2009-05-22 22:01

They can't be skipped? I remember in DP2, before I removed these intros myself, I was able to skip them with the ENTER key =/, if this is impossible to skip for others, then a feature to be able to skip them would be needed.

Kaltsu

2009-05-23 20:11

viewer   ~~0009352

How about just place an option to the MTA:SA settings if you prefer having the intro videos in the beginning or not? The MTA:SA splash screen is OK in my opinion.

eAi

2009-05-24 03:58

administrator   ~~0009359

Frankly, R are not about to sue MTA over removing the EAX/Nvidia logos. If nothing else, adding an option to the settings might be a solution that absolves MTA of direct responsibility for removing them, but quite frankly, nobody is going to care. Worst case, someone at R asks for them to be put back.

Flobu

2009-05-24 12:37

updater   ~~0009361

I think the best solution is to put the ads in the loading screen as first pictures instead of intros, like syntz mentioned it

karloz

2009-05-31 12:12

viewer   ~~0009465

I use this
http://www.gtaforums.com/index.php?showtopic=249766

It is a d3d9.dll to run gta in window mode and it automatically jump all intros.
I find it very useful.

Download link
http://files.filefront.com/GTA_Window_Mode/;5229192;;/fileinfo.html

jhxp

2009-06-22 17:25

administrator   ~~0009675

Should be done in 1.0 if possible.

Issue History

Date Modified Username Field Change