View Issue Details

IDProjectCategoryView StatusLast Update
0004303Multi Theft Auto : San AndreasClientpublic2009-05-28 19:15
ReporterccwAssigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.0 
Summary0004303: Some breakable objects have the incorrect animation
Description

Some breakable objects seem to think they are underground a little bit. This messes up the breaking animation.

Steps To Reproduce

Go to MTA Test server #1 and type this in the console:
votemap race race-ultimate hard drag
About half way down the course, there are some fences which break funny and further on there are some hay bales which also break funny.

TagsNo tags attached.

Activities

Talidan

2009-05-16 19:35

administrator   ~~0009251

Last edited: 2009-05-16 19:35

This is the case for all breakable objects, custom or from SA itself (find any old fence and break it), its easier to reproduce by simply starting broph and breaking one of the nearby wooden fences.

We've concluded its due to the jetpack and molotov fix - normally the broken pieces use a getGroundPosition to find where the broken pieces land. Since getGroundPosition now returns the object itself, it breaks in midair where the object's position is.

ccw

2009-05-20 23:09

administrator   ~~0009293

Fixed in r923

Issue History

Date Modified Username Field Change