View Issue Details

IDProjectCategoryView StatusLast Update
0004302New Feature Requests[All Projects] Generalpublic2018-08-03 21:15
ReporterJohnlineAssigned To 
PrioritylowSeverityfeatureReproducibilityN/A
Status closedResolutionwon't fix 
Summary0004302: [Request] col library support
Description

me and talidan weren't sure if this has been reported officially before, but rather dotted around in bug reports.
currently the game can properly load collisions for map objects only if they are separated out and contain 1 collision struct each. this is suitable for smaller custom map mods but doesnt scale well when mods start moving on to 5 or more objects, and makes it less accessible to people that dont have the tools/knowledge to manually dismember col files.
when using a col library with all collisions required merged into a col library, the game only loads the first struct in that library properly, the rest of the collisions are nulled.

i think what we need is efficient lua functions to reach within col libraries and somehow tie the correct col to the correct dff. by the way sa works it should be doing this automatically, but it seems unable to.

additionally, although arc_ has done great work to make cols stable, i still get the odd nulled collision on some custom objects, whether its if i've left the vicinity or not, seems quite random. reloading the resource immediately fixes it.

Additional Information

from discussion in mta, may be some useful background on how sa cols are done:

<rydenLaptop> Because right now they are indexed by some string, like the model name, made for IPL files &lt;rydenLaptop> But we don't use IPL files, we use lua functions
<ryden`Laptop> so how would you do that?

<Johnline> ipl lines use exactly the dff name:
10675, penisbuilding, 0, 360.1, -99.8, 7.1, 0, 0, 0.0, 1.0, -1
<Johnline> the dff (or maybe in the ipl line's case; the colstruct name)name is what references and locates the colstruct within any col library.
<Johnline> from what i've learned in sp sa, all col libraries are loaded into ram, and the game seeks until it finds a col struct with the same name as a dff being streamed in

<Johnline> so a col struct has no ambiguous referencing, it just sits in memory waiting for a dff with the right name to come along to pick it out from the .col library it is contained in.

<Johnline> i guess i should say the name of the col library in sp is irrelevant
<Johnline> cause nowhere in ipl, ide, dat files are the libraries themselves (stored idly in img archives) referenced.

TagsNo tags attached.

Relationships

has duplicate 0007866 closed New issues [Request] engineLoadCOL new argument 
related to 0002874 resolvedArc Multi Theft Auto : San Andreas Custom TXD and/or COL loading issues 
child of 0003344 closed New Feature Requests Requested features tracker 

Activities

Johnline

2009-05-17 04:57

viewer   ~~0009257

http://www.gtamodding.com/index.php?title=Collision_File

very useful info halfway down the page

ryden

2009-05-17 05:06

manager   ~~0009258

Priority updated due to the fact of that you can just split it into multiple .col files.

Talidan

2010-02-02 02:22

administrator   ~~0011034

Won't fix? Something to do with .col's not having proper references to their models.

Issue History

Date Modified Username Field Change