View Issue Details

IDProjectCategoryView StatusLast Update
0004293New issuesClientpublic2009-05-10 22:55
Reporter[PS]DazzaJay[AU]Assigned To 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionduplicate 
Summary0004293: [Request] warpPedIntoVehicle Client Side.
Description

i have been working very hard latley on some Cutscenes for the upcomming PS RP Server, and one thing has pissed me off numerous times.

Basically, ive been making the cutscenes client side, as they work extremley well like this, and i dont have to do any dimmension changing and stuff, so a cutscene can be happening right around other players and they wont see it.

The only problem that i have come across is, warpPedIntoVehicle is serverside only, making it a bastard.

i first tried triggering a serverside event to warp the ped into the clientside created vehicle, which didnt work. (no errors, just dosent work)

so then we moved the entire script serverside, which was worse, as most of the functions i use in the cutscene are Client side only. and also, now other players can see the cutscene happening around them (not very pretty what you dont see behind the camera)

but yeah, thats why i am requesting warpPedIntovehicle be made both server and Client side. (or even just give the serverside command the ability to warp player into a Clientside vehicle)

thanks.

TagsNo tags attached.

Relationships

duplicate of 0004228 resolved Multi Theft Auto : San Andreas warpPedIntoVehicle client-side 

Activities

trjack

2009-05-10 22:55

viewer   ~~0009169

Already posted!

mekorea

2009-05-10 22:55

developer   ~~0009170

http://bugs.mtasa.com/view.php?id=4228

Issue History

Date Modified Username Field Change