View Issue Details

IDProjectCategoryView StatusLast Update
0004286Multi Theft Auto : San AndreasClientpublic2009-05-28 19:16
ReporterrobholAssigned Toccw 
PrioritynormalSeveritytweakReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.0 
Summary0004286: Map download progress bar too obtrusive
Description

In my opinion the progress bar should be made less obtrusive, or removed. Since there's no real way to detect whether or not it's done (like the regular resource download) it ends up displaying long after the player has spawned and the game has begun.

I suggest that:

  • It should be made smaller and more discrete
  • It should preferably be moved to a more out-of-the-way area, instead of spinning around in the middle of the screen
  • It should have a Hide button, or maybe even an Always Hide button.
Additional Information

Since it's large and almost in the middle of the screen, it's quite distracting.
There's also the issue that people seemed to do just fine before it was displayed every single time they join a server.

How about caching map data like scripts? Only re-download if it's changed?

TagsNo tags attached.

Activities

eAi

2009-05-11 02:25

administrator   ~~0009191

An ajax-style spinner would make sense, e.g. http://www.ajaxload.info/cache/FF/FF/FF/00/00/00/5-1.gif

Arc

2009-05-11 02:27

administrator   ~~0009193

With a progress bar you can quickly decide whether a map is going to take too long to download (huge map and/or slow server) and quit immediately, rather than looking at a spinner (which would really only indicate that the game hasn't crashed)

robhol

2009-05-11 06:21

reporter   ~~0009199

Last edited: 2009-05-11 06:51

Fair enough, but moving it so it doesn't block your view while playing, and distract you with the animation of those two spinning arrows would be good. I suggest you leave the resource one as it is, but give the map download one some way to hide it, like a button? You could also make it movable so players can move it the hell off their screen if they want to... :P

Also (although this is slightly off-topic) map data should really be cached IMO. Not only would it eliminate this problem a lot of the time, but it would also "stress" each server and its bandwidth less. Not to mention, it took like 3-4 minutes for an 85kB download on freaking -localhost-, giving an average download speed of about 0.4kB/s...

ccw

2009-05-12 04:33

administrator   ~~0009212

Fixed in r814

Issue History

Date Modified Username Field Change