View Issue Details

IDProjectCategoryView StatusLast Update
0004282Multi Theft Auto : San AndreasScriptingpublic2011-01-07 00:36
ReporterGrimReaperAssigned ToTalidan 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.0.4Fixed in Version1.0.4 
Summary0004282: GUI overlays MTA menu
Description

Using guiBringToFront() makes the GUI element even overlay the MTA menu.

  • When using guiBringToFront() and open the MTA menu with the escape button, the GUI element overlays the MTA menu. Haven't tried if it also overlays the console, yet.
TagsNo tags attached.

Relationships

has duplicate 0004631 closed New issues GUI overlapping the main menu 

Activities

Arc

2009-05-09 16:23

administrator   ~~0009112

Last edited: 2009-05-09 16:23

Unable to reproduce with the following script:

addEventHandler('onClientResourceStart', resourceRoot,
function()
local win = guiCreateWindow(50, 50, 300, 200, 'test', false)
guiBringToFront(win)
end
)

Please provide a short script that does reproduce this.

GrimReaper

2009-05-09 16:37

viewer   ~~0009114

sry, i'm a bit confused. it's not guiBringToFront, but guiSetProperty using "AlwaysOnTop"

Cazomino05

2009-05-10 23:54

reporter   ~~0009180

Reproduced in r806, easy to reproduce by setting a random window like free roam "AlwaysOnTop" to "true"

Probably needs fixing at some point but isn't too important since it isn't used a lot

Talidan

2009-05-13 16:21

administrator   ~~0009228

Probably the best way would be to hook the property so that when its set, all of MTA's own menu items are re-set so that they take priority.

NeonBlack

2009-08-23 14:25

viewer   ~~0010337

Also drawn images (dxDrawImage) overlap the MTA menu.
Screenshot: http://neon-polas.de/img/mta/drawImageOverlap.jpg

x86

2009-10-17 12:34

administrator   ~~0010705

Download progress(when joining) overlays the mta main menu.

ryden

2011-01-07 00:36

manager   ~~0012480

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=1423

Issue History

Date Modified Username Field Change