View Issue Details

IDProjectCategoryView StatusLast Update
0004272Source patchesMulti Theft Auto : San Andreaspublic2017-06-18 19:58
Reporterlucasc190Assigned Toqaisjp 
PrioritynormalSeveritytweakReproducibilityN/A
Status closedResolutionwon't fix 
Product Version 
Target VersionFixed in Version 
Summary0004272: Local Player SetPedControlState Patch (Issue #0004267)
Description

This patch makes "setPedControlState" support the local player and depreciates "setControlState" and "getControlState".

It also makes "setPedControlState" and "getPedControlState"'s ped argument optional and default to the local player which allows the server "upgrade" command to upgrade them.

TagsNo tags attached.

Relationships

child of 0004267 resolvedqaisjp Multi Theft Auto : San Andreas Remove setControlState and make setPedControlState work on localPlayer 

Activities

CWanted

2013-12-22 22:58

updater   ~~0019846

What's up with this?

AlexTMjugador

2014-11-15 09:50

viewer   ~~0022362

Last edited: 2014-11-15 09:52

View 2 revisions

I support this patch with also the setAnalogControlState/setPedAnalogControlState functions. I don't really understand why are these functions separated, because ped functions are supposed to work in players too. It's like having, for example, getOccupiedVehicle/getPedOccupiedVehicle. It's more straightforward for newbie scripters to set a ped's control state also in the localPlayer (which is almost like a ped) than considering the localPlayer is a client, and thus requiring special functions to work with him because it's syncing his control states.

Grafu

2014-11-15 10:43

viewer   ~~0022365

Because setControlState is faster than setPedControlState and should be always called when you want to set the control state of the local player.

AlexTMjugador

2014-11-15 19:03

viewer   ~~0022382

The patch does that optimizasion automatically. Even if they're internally separated functions, I think that they should be integrated in the same Lua function for simplicity.

Issue History

Date Modified Username Field Change