View Issue Details

IDProjectCategoryView StatusLast Update
0004260Multi Theft Auto : San AndreasClientpublic2009-05-28 19:20
ReporterTalidanAssigned Tolucasc190 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.0 
Summary0004260: Entering an ambulance as driver gives the player 20hp (carried over from SP)
Description

Entering an ambulance as a driver gives the local player 20hp. This should be removed as it is easily replicated by script - and is much harder to counteract by script than to replicate.

More importantly however, this often triggers the anticheat and gives an autokick. I've experienced this most in Valhalla when bleeding (you slowly lose hp). Perhaps MTA sets a lower element health, then finds the health has magically gone up so triggers the kick.

TagsNo tags attached.

Relationships

related to 0003173 resolvedArc Multi Theft Auto : San Andreas Remove the ability to get weapons from vehicles 
related to 0004261 resolvedlil_Toady Source patches No Ambulance Health Gain Patch (Issue 4260) 

Activities

trjack

2009-05-05 11:38

viewer   ~~0009040

I repoduced this and it kicked me from the game with AC: You were kicked from the game.

I entered the ambulance with my HP set as 99.
Since the origional game only gives you 20HP if your health is less than 100.

Issue History

Date Modified Username Field Change