View Issue Details

IDProjectCategoryView StatusLast Update
0004215Multi Theft Auto : San AndreasGeneralpublic2011-01-03 03:47
ReporterDragonAssigned Toryden 
PrioritynormalSeverityminorReproducibilityrandom
Status resolvedResolutionfixed 
PlatformOSWindows XP Home EditionOS Version2002 SP 3
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0004215: Standing or walking when dead
Description

Sometimes when you should lie on the ground dead you stand on ground or walk (without moving away). the camera shaking starts and you get respawned after the given time. In general this is pretty random and it's never been like this in dp2. Anyway I found a way to reproduce this: http://www.youtube.com/watch?v=V8YAJ3wdxco

Steps To Reproduce

(tested in tdma)
get grenades
throw one near a wall with low health
get there and jump straight up
die in midair and hopefully see the bug

Additional Information

can be visible to local and remote player or only remote player, wasn't able to reproduce this so ONLY THE LOCAL BUT NOT THE REMOTE players can see it.

TagsNo tags attached.

Activities

Talidan

2009-04-24 17:36

administrator   ~~0008902

What about a midair /kill?

Dragon

2009-04-24 17:43

reporter   ~~0008904

nope kill in midair works fine with correct animation

lucasc190

2009-04-25 03:47

reporter   ~~0008908

I've noticed this happen after players fell to their death. When it happened, the player's simplest task was still "TASK_SIMPLE_IN_AIR". Kill in midair seems to also trigger it sometimes (depending on why they are in the air, for example, if you jump and kill, it doesn't seem to happen but if you teleport high up and kill it does).

Talidan

2009-05-05 04:05

administrator   ~~0009039

It also seems to happen if you die whilst entering a vehicle. Easily reproduced if you set yourself on fire (near death) and enter a vehicle. If you die whilst entering a vehicle, you'll start sprinting.

Cazomino05

2009-05-11 00:08

reporter   ~~0009182

Reproduced in r806, Talidans method was the easiest to use to reproduce

"Easily reproduced if you set yourself on fire (near death) and enter a vehicle. If you die whilst entering a vehicle, you'll start sprinting."
since I had a hard time using the method posted in the report itself.

In an ideal world this should be fixed but most resources re-spawn you straight away anyway

Dragon

2009-05-30 17:14

reporter   ~~0009460

the problem is that it looks terrible if others see you die that way

[CW]ExtremeR

2009-05-31 00:02

viewer   ~~0009463

Well, i reproduced this kinda bug in Race destruction derby mode. Sometimes when your car blows up, you just respawn on foot.

Dragon

2009-06-01 14:08

reporter   ~~0009489

I don't think that this has anything to do with this issue

ryden

2011-01-03 03:47

manager   ~~0012416

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=2175

Issue History

Date Modified Username Field Change